Unable to open appbuilder from withing PDSOE - Forum - OpenEdge Development - Progress Community

Unable to open appbuilder from withing PDSOE

 Forum

Unable to open appbuilder from withing PDSOE

This question is not answered

Hello,

 I'm having an issue with trying to open the Appbuilder from within PDSOE.  I'm getting the error below.    I can open the appBuilder fine outside of PDSOE.   I'm using  OE 11.7.2    I am receiving the following error message: 

 ** "adeweb/_rdwind.p" was not found .(293).        Any thoughts? 

TIA,

    Andre 

All Replies
  • You are running into a bug. I don't think adeweb/_rdwind.p exists. It is, however, attempted called when you open a WebSpeed program of a specific (and rare) version from PDSOE.  

    The WebSpeed program that is attempted opened has a version number that starts with WDT_v2. The version number is typically in the first line of the program as follows: &ANALYZE-SUSPEND _VERSION-NUMBER WDT_v2. There may be more after the 2.

    The call is done in an attempt to create a dummy window since the file in question is not 100% compatible with GUI AppBuilder even if it is a "structured" file with AppBuilder markup. I'm guessing it was built with WebTools or a short lived WebSpeed variant of AppBuilder. The standalone AppBuilder uses a different workaround to deal with this that probably works.

    I do not know enough about your situation or the file to know how to deal with this.

    You could report this to Support. Make sure you send us the file in question. We do not know how to create those files, we only know they may exist from reading old WebSpeed source code.

    You might search your source code and see how prevalent this is.  

    As far as I remember the only value provided by AppBuilder for "structured" WebSpeed files was to open them in a treeview and allow you to add procedures and functions. I do not remember how exactly we handle these in PDSOE (for the versions that work), but I suspect you can open these in the text editor and remove the AppBuilder markup. (Choose Source > Strip AppBuilder markup from the ABL Editor context (right-click) menu) without losing any functionality. (Note that there are some exceptions , like HTML mapping files)

    If you need to keep these files with the AppBuilder markup, it may be possible to open them in the standalone AppBuilder and edit somethng so they get regenerated in the correct format and version. (I do not know how much need to be changed for this to happen. I'm hoping almost nothing)  

    There is an _rdwind.p in adeuib. This is not likely to be the same as the one that probably once exited in adeweb, but you could try to drop it there and see what happens.