[icf-dev] WebClient, AIA and AppServer - Forum - OpenEdge Development - Progress Community

[icf-dev] WebClient, AIA and AppServer

 Forum

[icf-dev] WebClient, AIA and AppServer

  • Have any of you had success in setting up a deployment for a Dynamics application using the AppServer Internet Adapter (AIA) ?

    I ran into an issue yesterday where the AppServer that does the initial installation of the package is not able to authenticate the client because the coding procedures used in Dynamics on both the server and client side is not available on the client before the package has been installed. I managed to get around this after a suggestion from Bruce by setting up a separate AppServer without the Dynamics trimmings - with the sole purpose of installing the WebClient package.

    Now that I have gotten this far, I am having trouble with the needed connect string in the icfconfig.xml file to use the AppServer via AIA. I have triedvarious combinations of the string that was used before in the appsrvtt.d file - but without any luck. Does anyone have any idea what is needed here to make a connection to the AppServer successfully ?

    I have tried :

    -URL http://hostname/aia/Aia?AppService =oas_agdemo (with and without the -URL)

    I have an old appsrvtt.d file which used to work in 9.1B which had the following connect string :

    "Astra" "" "" yes no "" "" "A" "http://astra.mip-europe.com/aia/Aia?AppService=oas_010agdev"

    Anyone ?

    Thomas Hansen

    Managing Director

    ___________________________________

    MIP Europe A/S

    Ã…strupvej 53

    9800 Hjørring

    Denmark

    Tel.: +45 98 90 49 16

    Fax.: +45 98 90 49 17

    Mobile : +45 20 16 19 29

    E-mail : thomas@mip-europe.com

    Web : www.mip-europe.com

    Chairman - Danish Progress User Group

    __________________________________

    Dynamics-Based Astra2, AstraGen2 Global Application and AstraFin2 Financial Modules

        • Advanced Future Proof RAD Progress Enterprise Development ****

    To unsubscribe, e-mail: dev-unsubscribe@icf.possenet.org

    For additional commands, e-mail: dev-help@icf.possenet.org

  • Thomas

    Your connect string looks fine....we have managed to run our dynamics

    application using a Webclient connection and with our config xml file having

    the following connection parameter

    R#CHR(3)#-URL

    http://hostname/aia/Aia?AppService=AsEcomRelWe use ServletExec 3.1 software and there was an issue with Microsofts

    Virtual Machine that is shipped by default with NT and we have download

    another VM from the Sun Solaris website.

    What is the error message you are receiving?

    Clare

    -Original Message-

    From: Thomas Hansen

    Sent: 26 June 2002 08:40

    To: dev@icf.possenet.org

    Subject: WebClient, AIA and AppServer

    Have any of you had success in setting up a deployment for a Dynamics

    application using the AppServer Internet Adapter (AIA) ?

    I ran into an issue yesterday where the AppServer that does the initial

    installation of the package is not able to authenticate the client because

    the coding procedures used in Dynamics on both the server and client side is

    not available on the client before the package has been installed. I managed

    to get around this after a suggestion from Bruce by setting up a separate

    AppServer without the Dynamics trimmings - with the sole purpose of

    installing the WebClient package.

    Now that I have gotten this far, I am having trouble with the needed connect

    string in the icfconfig.xml file to use the AppServer via AIA. I have

    triedvarious combinations of the string that was used before in the

    appsrvtt.d file - but without any luck. Does anyone have any idea what is

    needed here to make a connection to the AppServer successfully ?

    I have tried :

    -URL http://hostname/aia/Aia?AppService =oas_agdemo (with and without the

    -URL)

    I have an old appsrvtt.d file which used to work in 9.1B which had the

    following connect string :

    "Astra" "" "" yes no "" "" "A"

    "http://astra.mip-europe.com/aia/Aia?AppService=oas_010agdev"

    Anyone ?

    Thomas Hansen

    Managing Director

    ___________________________________

    MIP Europe A/S

    Ã…strupvej 53

    9800 Hjørring

    Denmark

    Tel.: +45 98 90 49 16

    Fax.: +45 98 90 49 17

    Mobile : +45 20 16 19 29

    E-mail : thomas@mip-europe.com

    Web : www.mip-europe.com

    Chairman - Danish Progress User Group

    __________________________________

    Dynamics-Based Astra2, AstraGen2 Global Application and AstraFin2 Financial

    Modules

        • Advanced Future Proof RAD Progress Enterprise Development ****

    To unsubscribe, e-mail: dev-unsubscribe@icf.possenet.org

    For additional commands, e-mail: dev-help@icf.possenet.org

    To unsubscribe, e-mail: dev-unsubscribe@icf.possenet.org

    For additional commands, e-mail: dev-help@icf.possenet.org

  • Hi Claire,

    I have just installed JRUN 4 evaluation (which is fully functional) and do not have a separate JVM - am just using the JDK that comes with Progress 9.1C.

    I can test the AIA with http://hostname/aia/Aia?GetServletStatus without any problems. But when I use a string like the one you are using, then I get an error on the client : ry/app/rysessnid.p - ICFDB not connected. This usually happens when you are running client side but cannot connect to the AppServer.

    Thomas

    -Original Message-

    From: Clare Ward

    Sent: Wednesday, June 26, 2002 10:05 AM

    To: dev@icf.possenet.org

    Subject: RE: WebClient, AIA and AppServer

    Thomas

    Your connect string looks fine....we have managed to run our

    dynamics application using a Webclient connection and with

    our config xml file having the following connection parameter

    R#CHR(3)#-URL

    http://hostname/aia/Aia?AppService=AsEcomRelWe use ServletExec 3.1 software and there was an issue with

    Microsofts Virtual Machine that is shipped by default with NT

    and we have download another VM from the Sun Solaris website.

    What is the error message you are receiving?

    Clare

    -Original Message-

    From: Thomas Hansen

    Sent: 26 June 2002 08:40

    To: dev@icf.possenet.org

    Subject: WebClient, AIA and AppServer

    Have any of you had success in setting up a deployment for a

    Dynamics application using the AppServer Internet Adapter (AIA) ?

    I ran into an issue yesterday where the AppServer that does

    the initial installation of the package is not able to

    authenticate the client because the coding procedures used in

    Dynamics on both the server and client side is not available

    on the client before the package has been installed. I

    managed to get around this after a suggestion from Bruce by

    setting up a separate AppServer without the Dynamics

    trimmings - with the sole purpose of installing the WebClient

    package.

    Now that I have gotten this far, I am having trouble with the

    needed connect string in the icfconfig.xml file to use the

    AppServer via AIA. I have triedvarious combinations of the

    string that was used before in the appsrvtt.d file - but

    without any luck. Does anyone have any idea what is needed

    here to make a connection to the AppServer successfully ?

    I have tried :

    -URL http://hostname/aia/Aia?AppService =oas_agdemo (with and

    without the

    -URL)

    I have an old appsrvtt.d file which used to work in 9.1B

    which had the following connect string :

    "Astra" "" "" yes no "" "" "A"

    "http://astra.mip-europe.com/aia/Aia?AppService=oas_010agdev"

    Anyone ?

    Thomas Hansen

    Managing Director

    ___________________________________

    MIP Europe A/S

    Ã…strupvej 53

    9800 Hjørring

    Denmark

    Tel.: +45 98 90 49 16

    Fax.: +45 98 90 49 17

    Mobile : +45 20 16 19 29

    E-mail : thomas@mip-europe.com

    Web : www.mip-europe.com

    Chairman - Danish Progress User Group

    __________________________________

    Dynamics-Based Astra2, AstraGen2 Global Application and

    AstraFin2 Financial Modules

    *** Advanced Future Proof RAD Progress Enterprise Development ****

    To unsubscribe, e-mail: dev-unsubscribe@icf.possenet.org

    For additional commands, e-mail: dev-help@icf.possenet.org

    To unsubscribe, e-mail: dev-unsubscribe@icf.possenet.org

    For additional commands, e-mail: dev-help@icf.possenet.org

    To unsubscribe, e-mail: dev-unsubscribe@icf.possenet.org

    For additional commands, e-mail: dev-help@icf.possenet.org

  • Clare,

    Looks like what I was missing was the R#CHR(3)#-URL instead of just -URL. This seems to have done the trick.

    Thanks

    Thomas

    -Original Message-

    From: Thomas Hansen

    Sent: Wednesday, June 26, 2002 10:18 AM

    To: dev@icf.possenet.org

    Subject: RE: WebClient, AIA and AppServer

    Hi Claire,

    I have just installed JRUN 4 evaluation (which is fully

    functional) and do not have a separate JVM - am just using

    the JDK that comes with Progress 9.1C.

    I can test the AIA with

    http://hostname/aia/Aia?GetServletStatus without any

    problems. But when I use a string like the one you are using,

    then I get an error on the client : ry/app/rysessnid.p -

    ICFDB not connected. This usually happens when you are

    running client side but cannot connect to the AppServer.

    Thomas

    -Original Message-

    From: Clare Ward

    Sent: Wednesday, June 26, 2002 10:05 AM

    To: dev@icf.possenet.org

    Subject: RE: WebClient, AIA and AppServer

    Thomas

    Your connect string looks fine....we have managed to run our

    dynamics application using a Webclient connection and with

    our config xml file having the following connection parameter

    R#CHR(3)#-URL

    http://hostname/aia/Aia?AppService=AsEcomRelWe use ServletExec 3.1 software and there was an issue with

    Microsofts Virtual Machine that is shipped by default with NT

    and we have download another VM from the Sun Solaris website.

    What is the error message you are receiving?

    Clare

    -Original Message-

    From: Thomas Hansen

    Sent: 26 June 2002 08:40

    To: dev@icf.possenet.org

    Subject: WebClient, AIA and AppServer

    Have any of you had success in setting up a deployment for a

    Dynamics application using the AppServer Internet Adapter (AIA) ?

    I ran into an issue yesterday where the AppServer that does

    the initial installation of the package is not able to

    authenticate the client because the coding procedures used in

    Dynamics on both the server and client side is not available

    on the client before the package has been installed. I

    managed to get around this after a suggestion from Bruce by

    setting up a separate AppServer without the Dynamics

    trimmings - with the sole purpose of installing the WebClient

    package.

    Now that I have gotten this far, I am having trouble with the

    needed connect string in the icfconfig.xml file to use the

    AppServer via AIA. I have triedvarious combinations of the

    string that was used before in the appsrvtt.d file - but

    without any luck. Does anyone have any idea what is needed

    here to make a connection to the AppServer successfully ?

    I have tried :

    -URL http://hostname/aia/Aia?AppService =oas_agdemo (with and

    without the

    -URL)

    I have an old appsrvtt.d file which used to work in 9.1B

    which had the following connect string :

    "Astra" "" "" yes no "" "" "A"

    "http://astra.mip-europe.com/aia/Aia?AppService=oas_010agdev"

    Anyone ?

    Thomas Hansen

    Managing Director

    ___________________________________

    MIP Europe A/S

    Ã…strupvej 53

    9800 Hjørring

    Denmark

    Tel.: +45 98 90 49 16

    Fax.: +45 98 90 49 17

    Mobile : +45 20 16 19 29

    E-mail : thomas@mip-europe.com

    Web : www.mip-europe.com

    Chairman - Danish Progress User Group

    __________________________________

    Dynamics-Based Astra2, AstraGen2 Global Application and

    AstraFin2 Financial Modules

    *** Advanced Future Proof RAD Progress Enterprise Development ****

    To unsubscribe, e-mail: dev-unsubscribe@icf.possenet.org

    For additional commands, e-mail: dev-help@icf.possenet.org

    To unsubscribe, e-mail: dev-unsubscribe@icf.possenet.org

    For additional commands, e-mail: dev-help@icf.possenet.org

    To unsubscribe, e-mail: dev-unsubscribe@icf.possenet.org

    For additional commands, e-mail: dev-help@icf.possenet.org

    To unsubscribe, e-mail: dev-unsubscribe@icf.possenet.org

    For additional commands, e-mail: dev-help@icf.possenet.org