Running Eclipse / PDSOE on high DPI screens on Windows 8 and Windows 10 - Forum - OpenEdge Development - Progress Community

Running Eclipse / PDSOE on high DPI screens on Windows 8 and Windows 10

 Forum

Running Eclipse / PDSOE on high DPI screens on Windows 8 and Windows 10

  • This here fixed the issue with mini sized toolbar buttons in PDSOE on high DPI screens (Surface 4 pro) for me. As I didn't find it in the k-base I thought I share

    https://bugs.eclipse.org/bugs/show_bug.cgi?id=421383

    See the comment there by Matthew Cochrane 

    "For those with problems on high dpi displays such as Surface Pro 3 or Yoga 2 Pro, you can easily resolve this until eclipse is updated to work with high DPI displays in just two steps.

     
    1) Tell Windows to ignore settings from within applications (which are clearly wrong, since the UI is unusable) if a "manifest" file is available. Open registry editor and create the following DWORD registry key:
     
    Enable Windows to prioritise external manifests by creating and setting this registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SideBySide\PreferExternalManifest (DWORD) to 1
     
    2) Create a "manifest" file that tells Windows that Evernote is not using high dpi UI:
    Create the file eclipse.exe.manifest with the contents of the attachment to this bug "Manifest file to fix this issue on high DPI displays" and place it in the same folder as eclipse.ex.

    You may need to reboot your computer before starting Eclipse again.  Your UI is now normal!  Icons are correct sizes and all."

    My eclipse.exe.manifest file is here.

    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>

    <assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">

    <description>eclipse</description>

    <trustInfo xmlns="urn:schemas-microsoft-com:asm.v2">
      <security>
        <requestedPrivileges>
          <requestedExecutionLevel xmlns:ms_asmv3="urn:schemas-microsoft-com:asm.v3"
            level="asInvoker"
            ms_asmv3:uiAccess="false">
          </requestedExecutionLevel>
        </requestedPrivileges>
      </security>
    </trustInfo>

    <asmv3:application>
      <asmv3:windowsSettings xmlns="schemas.microsoft.com/.../WindowsSettings">
        <ms_windowsSettings:dpiAware xmlns:ms_windowsSettings="schemas.microsoft.com/.../ms_windowsSettings:dpiAware>
      </asmv3:windowsSettings>
    </asmv3:application>

    </assembly>

    Architect of the SmartComponent Library and WinKit

    Consultingwerk Ltd.

  • Mike,
     
    Thanks for finding this.
     
    I did find that on my Windows 10 VM running on top of an Apple iMac 5K retina display (5120x2880 resolution) that I had to put the manifest file in the following locations:
     

    -          $DLC\jdk\bin\javaw.exe.manifest

    -          $DLC\jdk\jre\bin\javaw.exe.manifest

    -          $DLC\jre\bin\javaw.exe.manifest

     
    I’m not sure which location caused things to start working but I have a usable Eclipse again.
     
    I owe ya a beer if I ever meet you in person.  :)
     
    Cheers, Brian

  • This seems to be the winner. I had to build a new laptop and I only have the following present.

    $DLC\jre\bin\javaw.exe.manifest

  • Hi,

    I just set the compatability mode to 'Windows Vista' and it works fine for me.

    Paul.

  • I wish it were the easy. On a WIN10 PC that did not work.

  • Hi,

    This was on Windows 10, on a Surface book 2.  3000x2000 resolution.

    I am running Elcipse Oxygen.2 (4.7.2)

    Paul.

  • Just installing a new laptop with Windows 10 (version 2004). In the properties of the shortcut (of PDSOE) on the compatibilty tab there's a "Change High DPI Settings"  button which you should click. In the High DPI scaling override section set the checkbox and select "System (enhanced)". That does the trick, at least for me.