Device Aplication VS2008 with Webservice Progress (WSA and ProxyGen) - Forum - OpenEdge Development - Progress Community

Device Aplication VS2008 with Webservice Progress (WSA and ProxyGen)


Device Aplication VS2008 with Webservice Progress (WSA and ProxyGen)

This question is not answered

Good morning,

We are developing a device Aplication in VS2008 to DataColection, and we are using webservice progress, which generate the sources * .re with proxygen we generate the WSDL to import the WSA with Tomcat and is working OK.
The problem starts when we connect the WebService via VS2008 or via Device Aplication the Collector, because does not present all the methods correctly after being imported into WebReference.
We did a test with aplication console and it worked perfectly.

Can anyone help us?


All Replies
  • The "premature end of file" parsing error means something is wrong with your SOAP message... either the content-type in the header is wrong or something is structurally wrong with the XML.

    You either need to appropriately debug in VS or you can use fiddler or something similar to grab the SOAP from both the one that is working and the one that is not and compare the XML.

  • I am not sure what you expect Progress to do here... nobody is paying for support on those licenses. This is something you need to get resolved because

    1) either you aren't paying to the support/maintenance

    2) you are paying TOTVS for support/maintenance of those licenses and they aren't paying Progress

    3) some kind of paperwork issue between TOTVS and Progress

    All of the being said... you don't have a Progress issue. You have a VS issue generating proper SOAP.

  • What is the day that Progress will take some responsibility and commit to the status of a client? The answer is: never.

    We want a position of progress, ie if the tool is incompatible, or has a workaround ..

  • > much inefficiency involved

    What is the inefficiency here? The product the call has been opened with does not have a maintenance contract. And there has to be if one wants to open a case. Either somebody used a wrong license to open a case with or simply nobody paid the maintenance contract for the given license.

    Since you like analogies: go to restaurant, have a full course meal there, and when asked to pay, try telling them that you have no money as people should help each other or that don't intend to pay as it is their fault that you were hungry at the first place and that it had to be reviewed urgently.

  • It makes no sense to his analogy.

    Whether is TOTVS (representative PROGRESS) or is directly PROGRESS, everyone is sitting behind a chair inactive and without any pro-activity to attempt to verify or even solve the problem, that's the fact.

    Like I said, if someone wants to really help us, help will be very welcome and even I'm here looking for just that, except that every time someone comes along wanting or difficult rather than easier.

  • The Case that Totvs has opened, 00318389, is being reviewed right now as to its status of Maint Hold.  As soon as this has been resolved it will be picked up by a support engineer.  The Support engineer will be communicating with Totvs on this issue through that case and not this community thread.

    I will also reach out to you shortly to discuss further via email.

    Glenn A Mulno

    Sr Manager Progress Technical Support

  • If you would exert as much energy to checking on the license as you are expending complaining about it, you might have the problem solved ... except that there is mounting evidence you don't even have a Progress problem here.

    No maintenance contract - no service.  This is hardly a strange and unusual requirement that violates industry norms.

    One might also note that you have a number of people here making some effort to help you and, after spending a lot of time ignoring our suggestions to log a support call, you are now spending more of your time complaining about the fact that you are not getting help without a maintenance contract than you are to responding to the feedback you are being given.

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice

  • jftalmeida,

    Can you please explain why you believe that this is a Progress issue ? I am not trying to block you or anything like that, but I would like to understand your situation. Please allow me to explain why I believe that this is not a Progress issue:

    - Works in VS2008 if you call the OpenEdge Web Service using "Application Console".

    - Works if you call the OpenEdge Web Service using SoapUI.

    - Only fails in VS2008 if you call the OpenEdge Web Service using "Device Application".

    So did you contact Microsoft for support ? The point of failure is with VS2008 from what I could understand and VS2008 is supported by Microsoft and not Progress.

    Also I am familiar with the example that was highlighted by Stefan Marquardt (worked with him many times in the past). His case was related to the ODBC connection from a .NET application to a Progress database. Initially it was a Progress bug which was fixed, then there was a Microsoft bug which was fixed and then it was a Progress bug again. Still the starting point was Microsoft since the point of failure was with their client application, so they are much better equipped to help us in debugging the client side.

    Going back to your analogy, it's like taking your car (OE Web Service) to the dealer (Progress) for an issue with your navigation (VS2008) which you bought at a store (Microsoft). So in your case I would also recommend that you start by contacting Microsoft for support. As I pointed out earlier with the KBase article, we have seen issues in the past with their .NET Compact Framework when calling Web Services.

  • Ok, thank you for those who tried to help solve the problem, regardless of whether it is or is TOTVS PROGRESS is or MICROSOFT.

    Honestly appear some comments that do not add and do not solve anything the situation, but to leave us even more destitute.

    Thank you anyway.

  • hi, I try to understand how you create the project. When you create the project, what .net framework version you use? what project type you select? because I cannot find any 'Device application' in my VS2008.

    I know there are 2 ways to reference the web service, but I am not sure if this is the root cause until I can duplicate what you did when creating the project.