.NET Framework 4 requirement for OE 11.4 - Forum - OpenEdge Development - Progress Community

.NET Framework 4 requirement for OE 11.4

 Forum

.NET Framework 4 requirement for OE 11.4

This question is not answered

If one installs OE 11.4 Developer Studio for OpenEdge on a clean system, the installation completes. When the course developer tries to create a new ABL Form in Developer Studio, an error is raised that .NET 4 is required.  Didn't we used to include the .NET framework in the installation of OE?  Is it documented anywhere that .NET 4 must be installed separately?

Elaine

All Replies
  • I think it still gets installed automatically on WinXP/Win7. It is a check box on the installation dialog. However, on Server 2008/2012 I believe you need to add the .NET framework yourself. Something to do with roles and the security.

  • My understanding is that the install checks for .NET 4 and should exit with an error if it is not there for PDSOE.
     
    Thanks
    -Shelley
     
    From: Elaine Rosenberg [mailto:bounce-erosenbe@community.progress.com]
    Sent: Friday, June 27, 2014 7:59 AM
    To: Beta.OE11.4@community.progress.com
    Subject: [Beta - OE11.4] .NET Framework 4 requirement for OE 11.4
     
    Thread created by Elaine Rosenberg

    If one installs OE 11.4 Developer Studio for OpenEdge on a clean system, the installation completes. When the course developer tries to create a new ABL Form in Developer Studio, an error is raised that .NET 4 is required.  Didn't we used to include the .NET framework in the installation of OE?  Is it documented anywhere that .NET 4 must be installed separately?

    Elaine

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.

  • Hi Elaine,
     
    There is an issue in our Bug database where OpenEdge installer fails to install .Net framework 4 on Windows 7 clean machine.
     
    Workaround: Installing the .Net framework post installation of OpenEdge will solve the problem.
     
    Thanks and Regards,
    Anil Kumar.
     
    From: schase [mailto:bounce-schase@community.progress.com]
    Sent: Friday, June 27, 2014 5:57 PM
    To: Beta.OE11.4@community.progress.com
    Subject: RE: [Beta - OE11.4] .NET Framework 4 requirement for OE 11.4
     
    RE: .NET Framework 4 requirement for OE 11.4
    Reply by schase
    My understanding is that the install checks for .NET 4 and should exit with an error if it is not there for PDSOE.
     
    Thanks
    -Shelley
     
    From: Elaine Rosenberg [mailto:bounce-erosenbe@community.progress.com]
    Sent: Friday, June 27, 2014 7:59 AM
    To: Beta.OE11.4@community.progress.com
    Subject: [Beta - OE11.4] .NET Framework 4 requirement for OE 11.4
     
    .NET Framework 4 requirement for OE 11.4
    Thread created by Elaine Rosenberg

    If one installs OE 11.4 Developer Studio for OpenEdge on a clean system, the installation completes. When the course developer tries to create a new ABL Form in Developer Studio, an error is raised that .NET 4 is required.  Didn't we used to include the .NET framework in the installation of OE?  Is it documented anywhere that .NET 4 must be installed separately?

    Elaine

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.