Updating a network installation - Forum - OpenEdge Deployment - Progress Community

Updating a network installation

 Forum

Updating a network installation

  • Hello.  I hope I've picked the right group - please let me know if I haven't.

    We installed a custom version of client networking 10.2B on a Novell server via a local workstation.  That local workstation is now gone.

    I would now like to do a full installation.  Or, if that's not possible, delete the installation and re-install.

    But the Installation and Configuration manual keeps pointing me to the Start Menu or Control Panel, but because I'm using a different workstation to access the network, the options I need aren't there.

    It feels like I'm missing something obvious - either a step/command that I should know, or a fundamental misunderstanding of how it all works.

    Would someone be able to enlighten me?

    Matt 

  • Reading through your question, you indeed picked the correct forum but I noticed no one yet got back to you...  

    Anyone following this forum has a suggestion for Matt?

  • Hi Matt, I wonder if this is what you are after: 

    Article: How to manually uninstall a shared network installation

    Please let me know if this helps.

    Molly

  • Thanks Molly.

    Is this what you're looking for Matt?

  • When I click the link it says:

    Group Not Found

    The requested Group cannot be found.

    I thought it might be because I wasn't logged in, but that doesn't seem to help.  The title certainly seems promising.

  • Try this link: Try this link: knowledgebase.progress.com/.../21698

  • That link worked.

    Unfortunately, the link describes uninstalling the netsetup installation on the client machines.  That I'm having no problem with because it's an individual workstation and would have the OpenEdge icon showing up.

    I'm trying to uninstall Progress from the network itself (I realize I wasn't clear - my terminology may be off).  

    Thus, in years past, I installed OpenEdge on the shared P: drive using a connected workstation that has since been replaced.  How do I uninstall it?

    I get the sense that all I need to do is delete the /dlc directory and it's gone.  Is it really that simple and I'm over-complicating things?

    (I'm a Unix guy, so the Windows portion of our application always has me treading warily)

  • Hi Matt,

    In essence, there are two type of OpenEdge installation for Windows: local and network install.

    Regardless of how you did it and what type you used, one way to uninstall it (as you don't have mapped P drive anymore I guess) is to do the following:

    1. Locate activex controls in your local installation directory and unregister them (regsvr32 /U blah.ocx)

    - they are usually (if not search for them) in %DLC%\bin\system, cscomb32.ocx, pstimer.ocx, csspin.ocx

    2. Unregister %DLC%\bin\prox.dll

    3. Remove registry HKEY_LOCAL_MACHINE\Software\PSC\ or HKEY_LOCAL_MACHINE\Software\Wow6432Node\PSC\ if it's win64 OS (this will remove references all Progres versions and products, so if you have other versions than 10.2B be aware of it - you will have to remove one by one otherwise)

    4. Do do the same for HKEY_CURRENT_USER

    5. Remove HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\AdminService10.2B

    6. Remove %DLC% install directory

    There are other registry entries, e.g file type association etc., buy they will get overwritten with new install.

    This is just from top of my head - I may have forgotten something, but it should work.

    If you get stuck, then just open ticket with tech support and they will assist you with it.

    ______________________________________________________
    There is a time to laugh and a time not to laugh, and this is not one of them.

  • "In essence, there are two type of OpenEdge installation for Windows: local and network install."

    I think I'm confusing everyone (likely because I am confused).  

    I installed the product called "Client Networking" on to a shared drive (P:) (with "Custom" selected).  I then used P:/dlc/netsetup/setup.exe to install Progress on various workstations for users.  

    I'm having no problems with the user installations.  I am not trying to uninstall anything from an individual workstation.

    What I'm trying to do, using a "fresh" workstation, is delete/complete the shared "Client Networking" installation.  It's not installed locally on the new workstation, so there is nothing in the local registry.

    I'm getting the sense that the proper course of action is:

    1) delete P:/dlc

    2) re-install P:/dlc

    3) for each machine currently networked, uninstall and re-install via P:/dlc/netsetup/setup.exe (may not be required)

    Thank you to everyone who has offered suggestions - it has helped clarify the situation so I'm pretty confident I'm not missing anything, I'm just assuming a simple process is more complex than it is.

  • Hi Matt,

    Greetings!!

    Will like to understand the scenario/requirement before finding the solution.

    Why do you want to delete the P:/dlc manually and re-install? why you are not able to see any OpenEdge related registry key in the machine ? Is it the case that machine where you have installed client network not available any more and all the registry key's are gone but DLC is still available as it is network/shared drive?

    Regard's

    Kousik

  • Hi Matt,

    Are you all set with this or do you need more guidance?

    Regards,

    John