integrateArchitect.bat -update error installing 11.7.4 - Forum - OpenEdge Deployment - Progress Community

integrateArchitect.bat -update error installing 11.7.4

 Forum

integrateArchitect.bat -update error installing 11.7.4

This question is not answered

I was attempting to update to 11.7.4 from 11.7.3 and received the error:

ProvisionEclipseDirs: Command "LaunchAppAndWait("C:\Progress\OpenEdge117\oeide\integrateArchitect.bat" -update)" failed.

The GetLastError was 13.

Click OK to continue.

I found the KB entry for this error in 11.7.3 and followed the Workaround step in proenv and received the same errors as described in the KB once again. The KB says that if that failed, which it did, I would have to go back and uninstall everything and reinstall 11.7, 11.7.1, 11.7.2, 11.7.3, and 11.7.4.

5 installs? This doesn't sound right. Are there any other answers?

I tried to open a Support Case but that doesn't seem to be working either. I guess it's not my day....

All Replies
  • You should wait for an official answer, but I was pretty sure that

    service packs are cumulative, i.e., 11.7 + 11.7.4 would be all that was

    required.

    Interestingly, I am getting an Access Denied message trying to post this

    on-line.

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice  http://www.cintegrity.com

  • Posting the KB article link will help others who can answer.

  • Hi,

    There is no need to install 11.7 FCS. 11.7.4 is a direct installer. We can get 11.7.4 artifacts with a single installation.

    Thanks,

    Ramadevi

  • Note there is a bug when direct installing 11.7.4, so you need to install it 2 times!

    knowledgebase.progress.com/.../

  • The KB article is 000089147 - PDSOE - PLUGIN NOT INSTALLED PROPERLY AFTER INSTALLING 11.7.3

    The errors in this KB article are the exact ones I am receiving. I am trying not to have to reinstall everything because I lose all of the Developer Studio plugins and configuration.

    Can this error be fixed without a reinstall?

  • Thanks, Torben. I checked the OpenEdge.Net.pl from the 11.7.4 install and the Properties match the ones match the "correct" version. So I don't think I have to install 11.7.4 again.