Multi-threaded error SearchRow RadGridView - Forum - OpenEdge Deployment - Progress Community

Multi-threaded error SearchRow RadGridView

 Forum

Multi-threaded error SearchRow RadGridView

This question is answered

Hi!

I´m trying to use the SearchRow of the RadGridView in progress. I active the searchrow using:

THIS-OBJECT:radGridView1:MasterTemplate:AllowSearchRow = TRUE.

But when I try to search it´s get an error:

"You are trying to use a multi-threaded .NET object in a way that is not supported.  The ABL cannot be called on a thread other than the main thread. (15740)"

Somebody find a anwser using progress. I try anything that I see but without success.

Thx for your help.

Verified Answer
  • I think the reason that I couldn't reproduce it with my code was that my example didn't use the binding source. It was putting data into rows directly.

    I looked through the source code for RadGridView and I don't see any way to tell it to not use a background thread for the search. I can't think of any way to work around this other than avoiding using the binding source, though I can't guarantee that even that would help.

All Replies
  • What version of OpenEdge and what version of Telerik UI for Winforms are you using? I created a simple example in 11.7 with UI for Winforms 2016.3.1024.40 and I don't see the issue.

  • Hi, Matt.

    Thanks for your reply, I´m using OpenEdge Release 11.3.3 and  UI for Winforms 2015.1.331.40.

    Thanks.

  • I'm not seeing the issue with 11.3.3 and 2015.2.728.40, which is the closest version I have on hand.

    It may be that my code doesn't do the right things to see the issue. Could you post a zip file with a small reproducible example?

  • Hi, Matt.

    I think that you can test this code, only include it into a project connected to db sports 2000 of progress and substituted in the binding for the table.

    Thx.

    4113.GridViewTest.cls

  • I can see the issue with your code. Unfortunately, if the control uses multi-threading for the search it may not be possible to make it work with OpenEdge. I'm looking to see if there are any known workarounds.

  • I think the reason that I couldn't reproduce it with my code was that my example didn't use the binding source. It was putting data into rows directly.

    I looked through the source code for RadGridView and I don't see any way to tell it to not use a background thread for the search. I can't think of any way to work around this other than avoiding using the binding source, though I can't guarantee that even that would help.