To configure: Keyword Case = Upper Case - Forum - OpenEdge Deployment - Progress Community

To configure: Keyword Case = Upper Case

 Forum

To configure: Keyword Case = Upper Case

This question is answered

Hello,

I would like resolve the little issue, always that I open Procedure Editor, I set in Options -> Editing Options... -> Options and selected Upper case in Keyword Case and click in the button OK and OK, but if I close the editor and open a new session this option don´t are salve. How do I set this option? I already looked in the ini file but I did not find anything related to that.

OpenEdge Version is 11.3.3

If someone can help.

Thanks.

Verified Answer
  • The EditorConfigPath entry tells the Procedure Editor where the settings from the Editing Options dialog box are stored. That's why I'm asking you to make sure that the AVM is using the right ini file and whether it contains EditorConfigPath.

  • The editor checks whether it's able to write to vslick.sta. If it can't write to that file it won't save your settings when the Procedure Editor is shut down. Please make sure that vslick.sta is not read-only and that you have full permissions on the file.

All Replies
  • This option doesn’t change existing code.
     
    To do that, select the code to change (CTRL-A) and CTRL-SHIFT-F  (Correct Case). Also available via right-click Source > Correct Case.
     
  • First, make sure that the AVM is using the ini file that you think it is. You can see which ini file it's using by starting the Procedure Editor and pressing Ctrl-Alt-Shift-F1 (all together). This will display a dialog box which shows the ini file path in a box labeled "PROGRESS.INI Directory".

    Does your ini file contain an EditorConfigPath entry? Do you have write permissions in that directory?

  • Sorry, maybe I did not express myself correctly but every time I enter the Editor I need to check the option for the code I am writing in the uppercase, this option is not checked the next time I enter the editor.

  • The EditorConfigPath entry tells the Procedure Editor where the settings from the Editing Options dialog box are stored. That's why I'm asking you to make sure that the AVM is using the right ini file and whether it contains EditorConfigPath.

  • Hello Matt,

    Yes the ini file is right, I confirmed with Ctrl+Alt+Shift+F1, exist the entry: EditorConfigPath=W:\OE11_srv\proedit, in this directory I didn´t have permission but now I have, now I can create new file in this directory (W:\OE11_srv\proedit) but same way the option don´t save if I leave editor and open a new session.

    Some idea to resolve?

    Thanks for help.

  • The editor checks whether it's able to write to vslick.sta. If it can't write to that file it won't save your settings when the Procedure Editor is shut down. Please make sure that vslick.sta is not read-only and that you have full permissions on the file.

  • Something stranger because I have full permission in this file and the settings don't are save, but it already helped me, when there is nobody connected I change the file by one with the correct configuration.

    Very thanks.

  • That explains it. If someone else is using the Procedure Editor from the same installation you won't be able to save settings. Only the first user to open the settings file is allowed to modify it. Otherwise it could get corrupted.

    You can have your own private settings by making a copy of the proedit directory and pointing EditorConfigPath to your copy.