Webclient update problem on Windows 10 - Forum - OpenEdge Deployment - Progress Community

Webclient update problem on Windows 10

 Forum

Webclient update problem on Windows 10

This question is answered

Hi

Upgrade to a new application package fails to happen unless the application was started with "Run as Administrator" option. The expected behavior would have been for the application to rather fail and not to run at all. a Subsequent attempt after "Right Click" and "Run as Administrator" selection did lead to a successful upgrade.  

The UAC setting on my PC is set to the minimum.

I hope someone may shed some light on this.

Merwe Fourie

Verified Answer
All Replies
  • Since Windows 10 has only recently been released, I am guessing you had the application previously installed on Windows 7 or 8, and upgraded to Windows 10. Did you "Run as Administrator" when you originally installed the application?

    IIRC, OpenEdge is not officially certified on Windows 10 yet, there are discussions in the forum concerning this. After getting more information (e.g an easily reproducible case) you could log a bug for this with TS, with the understanding of the current certification of OE.

  • And also include your OE/WebClient version in postings, as some of these issues might have been addressed in later versions.

  • We are running on windows 10 just fine. We do either need to "Run as Administrator" or setup the Permissions for the registry key of your WC application to give full control to the user(s) that will run the application.

  • I have indeed upgraded from Windows 7 to Windows 10 and yes the application was installed on Win 7 originally where there was no need for "Run as Administrator". The same have happened with two different 10.2B applications. I am aware of the current certification and therefore will for the moment request the end users to stay away from Win 10 for what it is worth.  Both applications does include dll and ocx libraries managed through the "Systems Tasks Definitions" tab but none of these files have changed. We normally had issues and had to do the initial install logged into an Administrator account but never was it necessary to "Run as Administrator" on top of being an administrator. Normal application updates was never a problem. I hope this does not call for a re-install. This I will test. I will see what I can do towards reproducing the scenario.  

  • Are you saying that if you are logged in as Administrator, you still have to "Run As Administrator" to install the upgrade, where you didn't have to do this in Windows 7?

    As rblanchard says, if you open up your permissions to the appropriate places, this should work correctly. Alternatively, you could opt for a Personal install, if these are not shared machines.

  • That is correct yes. Thank you I will check the rights issue out. Personal install may be the better route in the long run.

  • Gary,

    Even if you are logged in as an Administrator if you do not check the "Run As Administrator" option you need to grant full access under permissions in registry. This started in WIN8 from what I remember. I think it has something to do with UAC.

  • Seems rights are the root cause. The problem however is that if users do not "Run as Administrator" they continue unchecked to use the system without being forced to update. This should not happen. Any ideas how to manage this for an existing application? In real live we neither control nor can we predict when users may upgrade to Win 10. Upgrading   can cause them to keep running outdated code. Perhaps this already did happen with Win 8!  

  • Does this still happen if you open the registry and file system permissions, as rblanchard suggested?

    I would suggest contacting Tech Support to log a bug (assuming it happened in Windows 8, not just Windows 10). Please provide a reproducible case.

  • Gary,

    It does happen on WIN8 as well as WIN10.

  • Though I have yet to upgrade to Windows 10, but I do have similar experience on Windows 8; setting UAC to minimum still does not give full administrator rights. To permanently gain FULL administrator rights, you need to modify registry setting.

    Do the following:

    1. Navigate in registry (regedit), 'HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Windows > CurrentVersion > Policies > System'.
    2. Change 'EnableLUA' value from 1 to 0 (hex).
    3. Reboot machine and done.