00448055 - (QAD) Conversion of BPM DB from 8.0 to 11.6 - Forum - OpenEdge BPM - Progress Community

00448055 - (QAD) Conversion of BPM DB from 8.0 to 11.6

 Forum

00448055 - (QAD) Conversion of BPM DB from 8.0 to 11.6

This question is not answered

When migrating the BPM DB do we first need to migrate to base version and then apply the service pack? OR we can directly migrate to a version with service pack?

For e.g version 8.0 to 11.3 and then migrate to 11.3 to 11.6 (base version) and then apply the service pack? OR directly 11.3 to 11.6.3.

Please advise.

Thank you,

Mansi

All Replies
  • Hi Mansi,
     
    You can migrate to service pack version directly(11.6.x) instead of going to base version. Migration utility allows you to migrate from 11.3.x version to any latest version/any latest service pack version.
     
    Thanks,
    Praveena
     
  • Hi Praveena,

    We may get on a call with the customer some point today to confirm their steps.

    Based on the description in the case, some bits vague, I think the customer might be doing something like this:

    1. Since DLC/oebpm/server/migration in 11.6.3 does not have the 8.0 -> 11.3 migration tool, they probably copied over the tool from an OE 11.3.2 installation into this 11.6.x install.

    Invalid Target SBM Version: 11.6.3. Target SBM Versions can only be 11.3.x <- might be a user error, if they put the target.version=11.6.3 (Running 11.6.3, so target version should be this value... is an assumption).

    2.  They update the oebps.target.version=11.3.2 in the migration.properties in the 8.0 -> 11.3.2 migration process.

    Then they try to run the migration tool from this 11.6.3 instance, where they see mismatch between oebps.version in oebps.conf (11.6.3) and the oebps.target.version=11.3.2 (in the migration.properties). So, the migration is not moving forward.

    Value <11.6.3> specified for property <oebps.version> in </dlc/116/oebpm/server/conf/oebps.conf> does not match value <11.3.2> specified for property <oebps.target,version> in </dlc/116/oebpm/server/migration/8.0-11.3/conf/migration.properties>

     

    What would be the best way to get 8.0 -> 11.6/11.7 migration done, without having to setup an intermediate 11.3 / 11.3.2? Is it doable?

  • Hi,
     
    Migrating to OpenEdge 11.3.0 is a mandatory step when someone is coming  from Savvion 7.6/8.0, after migrating to 11.3.0 they can migrate to any higher/newer version of OpenEdge. Copying the zip file from older version to newer version and running it is not recommended as you may end up with few more issues. The utility is designed to run on those specific versions, hence copying it to other version is not suggested.
     
    Thanks,
    Praveena