Apparent licensing change after enabling Windows firewall and Windows update - Forum - OpenEdge Architecture - Progress Community

Apparent licensing change after enabling Windows firewall and Windows update

 Forum

Apparent licensing change after enabling Windows firewall and Windows update

  • We installed our first application on Windows 2008 (DB/Appserver/WS and web server machines) and set up administration via OpenEdge Management.

    We then turned on Windows firewall and Windows updating on both machines and rebooted.  Now when we try to access the db or appserver from Open Edge Management we get these messages:

    Database not licensed for container: ip-0a60c33a

    AppServer not licensed for container: ip-0a60c33a

    We haven't found clear answers in the KB or documentation.

    All comments and suggestions appreciated.

    Thank you.

  • Hi John,

    well that's very strange.  Is there a progress.cfg file in C:\Progress\OpenEdge?

    if there is, then select Start --> Programs --> OpenEdge --> Config - what products does it say?

    Also feel free to email my directly on this issue. 

    Roy

  • Yes, 'config' lists Enterprise RDBMS, OE Application Svr Ent, OpenEdge Repl Plus, Name Server Load Balance, OpenEdge Architect, OpenEdge TDE, OpenEdge Mgt. SE.

  • Roy,

    Any update on this question?

    Thank you,

    John

  • Okay, after some investigation with John, I think we found the problem. 

    The problem was the AdminServer when it started could not read the Progress License file.  Therefore OE Management had no valid licenses for managing nor monitoring AppServers or Databases.  A restart of the AdminServer fixed the problem and the environment is now working as expected.

    Now what caused the problem?  My assumption is that the machine was rebooting after having the Windows Firewall installed and several Windows Updates; so at restart the AdminServer was competing with many other services at startup, including configuration of the firewall and the updates.  Restarting the AdminServer without the system contention fixed the problem.

    Roy

  • Hi Roy,

    We had similar problem with OE/Mngmt Explorer. It was working fine until our server was rebooted, all monitoring resources didn't show up after the reboot.

    When trying to add a new appserver resource, it said "AppServer is not licensed."; the admin server log also shows same message for nameServer, webspeed and database.

    asbman and dbman utility are working fine. We also re-installed 102B a couple of times, still the same problem for OE Explorer. The server reboot must have applied some sort of windows update that caused this problem. Can you help please?

    Regards

    Kevin

  • Hi kevin , was your problem solved at that time. cause we are facing same problem with openedge 11.1 and also with openedge management 10.2b . I think its some kind of system problem with plugins. Please let me know.

    Thank you

  • Hi Sushil,

    Can you check the license for these machines?

    If on Windows you can select the "Config" link in the "Progress" start programs section.

    If on Linux, run "/psc/version#/dlc/bin/showcfg ../progress.cfg"

    Please check for the expiration dates and let me know what you find.

    Regards,

    Roy Ellis

    ellis@progress.com