AutoEdge - Installation issues - Forum - OpenEdge Architecture - Progress Community
 Forum

AutoEdge - Installation issues

  • I'm no expert on Sonic either, so I always leave all settings at their default when I install it. But I will setup a new machine later today and look out for anything that I might change but don't remember right now.

    IIRC, if you install MQ and ESB, there should not be a username / password (but IIRC correctly it will still work if you supply one). If you install workbench (which is what we used for AutoEdge and what the installation docs assume) the username and password should be "Administrator".

    Maybe the error message is just misleading and something is wrong with the connection info in workbench? Maybe you changed some values? Try this:

    Start the domain manager directly (start - Sonic Software - Sonic Workbench 7.0 - Start Domain Manager)? You should see two important lines:

    " (info) "Domain1.DomainManager" starting..." (at the top)

    " ID=MgmtBroker (info) TCP_ACCEPTOR: accepting connections on tcp://cstiller-vm-2:2506" (at the bottom)

    Then start the management console directly (Sonic Software - Sonic Workbench 7.0 - Sonic Workbench Components - Sonic ESB - Management Console). Put in the info from the strings above (mainly domain name and connection URL - "Domain1" and "tcp://cstiller-vm-2:2506" in my example here).

    Now try this with the default (user "Administrator" and blank password") and with a password (both user and pass "Administrator"). Hopefully one of the two should work... If not, I'm not sure where to go from here, but again I'm no Sonic expert so someone else might have more suggestions.

  • I'll give this a try as soon as I can ... a disk died in my workstation and I am currently waiting to see it it can be recovered or if I am going to have to rebuild the whole machine from scratch.

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice  http://www.cintegrity.com

  • Documentation bug.

    In OpenEdge Application Example AutoEdge Installation and Release Notes page 6 the incorrect URL is given for the Crystal customized report viewer. It should be:

    Index of ftp://ftp.progress.com/pub/AppliedTechnology/AEInstall/CrystalXIrdc.msi

    The October 06 version, at least, omits the AEInstall part of the path.

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice  http://www.cintegrity.com

  • Documentation bug.

    In OpenEdge Application Example AutoEdge Installation

    and Release Notes page 6 the incorrect URL is given

    for the Crystal customized report viewer. It should

    be:

    Index of

    ftp://ftp.progress.com/pub/AppliedTechnology/AEInstall

    /CrystalXIrdc.msi

    The October 06 version, at least, omits the AEInstall

    part of the path.

    Thanks.

  • I have posted an updated version of AutoEdge at http://www.psdn.com/library/entry.jspa?categoryID=298&externalID=1696. The installation executable as well as the zip file are new. This version works with 10.1A01 and 10.1B. The document bug found this week has been fixed as well.

  • So, as far as I could tell, I completed all of the installation process without any problems, but now when I try to bring up the Consumer screen with

    http://localhost/scripts/cgiip.exe/WService=wsAutoEdgeHQ/autoedge/home.p

    I am getting a page not found.

    Where do I look to see what is not what?

    I can bring up he .NET form.

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice  http://www.cintegrity.com

  • Have you used WebSpeed on that machine before? If you get a "real" page not found (the white one from the webserver, not the yellow one from WebSpeed) chances are something is not setup correctly.

    Try starting the sample broker that comes with the product install (launch Progress Explorer, connect to locahost, login, go to WebSpeed, select wsbroker1, right click and select start).

    Then go to your webbrowser and run "http://localhost/scripts/cgiip.exe/WService=wsbroker1/ping" . If you don't get a "WebSpeed Transaction Server successfully accessed" message, you need to fix configuration.

    Here are some pointers (assuming you use IIS):

    - check that IIS is running (right click on "my computer", select manage, Services and Applications, Internet Information Service, WebSites, Default WebSite

    - check that there is a scripts directory (that's one of the options during install of IIS, but I think it's not checked by default). If it isn't, I think the easiest way to add it with all the proper setting is to run the windows installer again and then select that option. The default directory is c:\inetpub\scripts

    - check that the cgiip.exe file from the Progress Install is in that directory, and that it is the correct version (e.g. 10.1B instead of 10.1A). Just copy it from the DLC/bin directory. If you need both 10.1A and 10.1B WebSpeed on the same machine, rename one and change the filename in all URLs (should be only the one in the start menu for AutoEdge)

    LEt me know if this solves the issue or not...

  • This didn't work, but after finding that there was no scripts

    directory, I went to the add Windows Components and drilled down in

    details until I found the check box for it, check it, and the

    directory appeared. I copied over both cgiip files. Now that page

    works and I can run the consumer web example with no problem.

    Consulting in Model-Based Development, Transformation, and Object-Oriented Best Practice  http://www.cintegrity.com

  • Have downloaded 'AutoEdgeSetup 20070119.exe' and attempted to install, but get:

    "This version of AutoEdge requires OpenEdge 10.1A01 or higher"

    Installed is:

    OpenEdge 10.1A Shared Network Installation (10.1A02)

    PROGRESS 9.1D Shared Network Installation

    Windows XP SP2

  • Struth! I'll have a look and get back to ya! Wait! Shared network install??? What does this mean: did you run netsetup? Or are you running OpenEdge 'manually' from a network share? Probably some registry setting problems. I'll have a look.

  • Hi,

    I have looked at the installation source and your issue seems related to the fact that the NETSETUP or your installation does not have a registry key defined for the OpenEdge installation (and service pack level).

    The install checks the following registry key(s) for the OpenEdge version installed and get the DLC value:

    HKLM\SOFTWARE\PSC\PROGRESS\\Startup

    If it finds an OpenEdge 10.1A installation, it checks for the Service Pack level in the following key:

    HKLM\SOFTWARE\PSC\PROGRESS\10.1A\ServicePack\Level

    For OpenEdge 10.1B, no Service Pack level check is performed.

    If possible, can you send me your registry information of your local machine setup (HKLM\SOFTWARE\PSC if available and the HKCU\SOFTWARE\PSC) for Progress?

  • Thanks Frank, I have sent the two registry exports directly to you.