JET templates and swedich characters - Forum - OpenEdge Architecture - Progress Community

JET templates and swedich characters

 Forum

JET templates and swedich characters

This question is answered

When I create JET templates, the Swedish characters (åäö) is change to "?" when the javafiles * .java is created. How do you do to keep the Swedish characters.

Mikael

Verified Answer
  • Looks like an issue with the encoding. Can you try using UTF8 (by default Eclipse/PDSOE uses CP-1251).

    You can change it either at workspace level or project level.

    For Workspace level settings:

    Window > Preferences > General > Workspace, change the Text file encoding from Default (Cp1252) to UTF8.

    These steps might be different based on version of Architech (PDSOE)/Eclipse you are using - which version are you using?

    Regards

    Suresh

All Replies
  • Looks like an issue with the encoding. Can you try using UTF8 (by default Eclipse/PDSOE uses CP-1251).

    You can change it either at workspace level or project level.

    For Workspace level settings:

    Window > Preferences > General > Workspace, change the Text file encoding from Default (Cp1252) to UTF8.

    These steps might be different based on version of Architech (PDSOE)/Eclipse you are using - which version are you using?

    Regards

    Suresh

  • Now I get the swedich characters. Thank's

    /micke

  • you don’t have to use utf-8 for this. utf-8 is a multi-byte character set but there are single-byte alternatives.

    it might be more convenient to use whatever character set is normally used in sweden.

    ISO-8859-15 is common for much of wester europe.