OE Mobile TestDrive - Forum - Mobile - Progress Community

OE Mobile TestDrive

 Forum

OE Mobile TestDrive

  • Any pointers appreciated. I'm trying to walk through the mobile test drive and when I run the thing, I always get a "Failed to log in" message. I've been back through the instructions several times and even started a new session from scratch to try it all again, no luck. I always get to the point to launch it, it opens the web browser and goes to the app but get's a pop-up that says "Failed to log in".  I put my credentials in as the first part of the instructions show, but I must be missing something.

    I'm doing the test drive on one of the aws installations fwiw.

    andy

  • I am out of the office until May 6th 2013. I will not be checking my mail and phone on a regular basis, but will reply to your mail as soon as I can.

    If you need support from appSolutions, please send your mails to support@app-solutions.com.

    If you need Roundtable support, please send mails to :

    support-europe@roundtable-tsms.com.

    Jeg er væk fra kontoret indtil den 6. maj 2013, og checker ikke mail og telefon regelmæssigt. Jeg vil dog svare på din mail så snart som muligt.

    Hvis du har behov for support, kontakt venligst support@app-solutions.com, så vender vi tilbage så snart det er muligt.

    Administrative henvendelser kan ske til : admin@app-solutions.com.

    Med venlig hilsen / Regards

    Thomas Hansen

    appSolutions a/s

    Regards / Med Venlig Hilsen 

    Thomas Hansen
    Director
    ___________________________________
    appSolutions a|s

  • Hello,

    The login code on page 55 in the OpenEdge Development Mobile Applications book is missing the definition of variable cMsg.

    The variable definition should look like the following:

    var cMsg = "ok";

    var pdsession;

    var settings;


    See discussion http://communities.progress.com/pcom/thread/54166 for a listing of the code.


    There is also a reference to this from the "Debugging Tips for debugging OE Mobile":

         http://communities.progress.com/pcom/message/170055

    I hope this helps.

  • Already have the cMsg variable declared and set to "ok".

    But, thanks for the other links, I'll dig through some of that to see if I can find an issue.  I did actually change my service name from "MyMobileService" to "AMobileService" but I've been over all of my code and settings and the name is right everywhere. Unless the "MyMobile" may be burried in something copied into the tomcat webapp somewhere?

    Thanks again. Any pointers are apprecited.

    --EDIT:

    It wasn't the cMsg, but your post did help me fix my problem... I'm not completely sure I understand it though. I had also declared the pdsession variable up in the top of my code, so I had:

    var settings;
    var cMsg = "ok";
    var pdsession;

    try {
      /* CHANGE THIS TO POINT TO YOUR SETTINGS SERVICE */
      settings = MyMobileService_dsCustomer_Settings;
      pdsession = new progress.data.Session();
      ...
    So I saw the code you posted did not have that defined. I commented that out and it worked!  Still scratching my head about that though...

    --END EDIT:
    Thanks!
    andy
  • You are welcome.

    The message ""Failed to log in" is displayed when there is an exception in the code that performs the login.

    The exception then is written to the JavaScript console. The message should give you an idea on why commenting out the definition made it work.

    I hope this helps.

  • Found the issue. Bit myself by changing two things :-)

    Had nothing to do with the variable definition. When I commented that line out, I had noticed that my "ServiceURI" had a capital "S" in my code and I lowercased it. That is actually what fixed it because that was lowercase in the mobile app builder, not capital. Fun with case sensitivity!

    Thanks again for the help. Answer was there all along, but didn't really think about the case-sensitive thing.

  • It is, for better or worse, one of the things you'll have to get used to thinking about. That and 0-based counting :-/.

    -- peter

  • The issue with the capitalization "serviceURI" has already been reported.

    As you have found out, MobilityDemoService_dsCustomer_Settings is a JavaScript object and the parameters from the services page are properties of the object. JavaScript properties and functions are case-sensitive.

    Since the name of parameter should be "serviceURI" and not "ServiceURI" (to be consistent with the naming conventions), you could change the name of the parameter in the services page.

    Thanks.

  • I believe issues discussed in this thread are related and captured in the following 2 knowledge base articles:

    http://knowledgebase.progress.com/articles/Article/000038840?retURL=%2Fapex%2FProgressKBHome&popup=false

    http://knowledgebase.progress.com/articles/Article/000039150?retURL=%2Fapex%2Fprogresskbsearch&popup=false