Can't publish mobile service - Forum - Mobile - Progress Community

Can't publish mobile service

 Forum

Can't publish mobile service

  • publish_service.jpg

    I tried to go "step-by-step" through demo from "Webinar-Modernize Your Existing OpenEdge Applications with Kendo UI"

    https://community.progress.com/community_groups/mobile/w/mobile/2437.webinar-modernize-your-existing-openedge-applications-with-kendo-ui.aspx

    and I stopped because of error during publishing project. The message was: "Server returned 403 Forbidden for https://localhost:8443/oemanager/applications/oepas1/webapps/Sports/transports/rest/oeservices with an HTML response".

    Earlier I had some problems with creating Pacific server described in thread

    https://community.progress.com/community_groups/openedge_general/f/26/t/19643.aspx

    "Server returned 403 Forbidden for https://localhost:8443/oemanager/applications/oepas1/webapps/Sports/transports/rest/oeservices with an HTML response". - See more at: https://community.progress.com/community_groups/openedge_general/f/26/t/19643.aspx?pi20882=3#sthash.iQnsv0aW.dpuf
    "Server returned 403 Forbidden for https://localhost:8443/oemanager/applications/oepas1/webapps/Sports/transports/rest/oeservices with an HTML response". - See more at: https://community.progress.com/community_groups/openedge_general/f/26/t/19643.aspx?pi20882=3#sthash.iQnsv0aW.dpuf
    Webinar - Modernize Your Existing OpenEdge Applications with Kendo UI - See more at: https://community.progress.com/community_groups/mobile/w/mobile/2437.webinar-modernize-your-existing-openedge-applications-with-kendo-ui.aspx#sthash.FxZ7plM9.dpuf
    Webinar - Modernize Your Existing OpenEdge Applications with Kendo UI - See more at: https://community.progress.com/community_groups/mobile/w/mobile/2437.webinar-modernize-your-existing-openedge-applications-with-kendo-ui.aspx#sthash.FxZ7plM9.dpuf
    Webinar - Modernize Your Existing OpenEdge Applications with Kendo UI - See more at: https://community.progress.com/community_groups/mobile/w/mobile/2437.webinar-modernize-your-existing-openedge-applications-with-kendo-ui.aspx#sthash.FxZ7plM9.dpuf
    Webinar - Modernize Your Existing OpenEdge Applications with Kendo UI - See more at: https://community.progress.com/community_groups/mobile/w/mobile/2437.webinar-modernize-your-existing-openedge-applications-with-kendo-ui.aspx#sthash.FxZ7plM9.dpuf
  • Can you check whether there's a 'oemanager' folder in the 'webapps' folder of your oepas1 instance?

    Otherwise you need to deploy oemanager.war first for your oepas1 instance which you can find in $DLC/servers/pasoe/webapps.

  • oemanager is supposed to be deployed in your development environment(oepas1 instance) by default. I remember you said you created the instance by using tcman and it was not tailored while installation because of your powershell issues. You might want to check your instance once

    In future, if you are going to create a instance and you want it to be equivalent to your development instance then you can do that by providing "-f" parameter in tcman.bat create command

    pasman create -p <http-port> -P <https-port>  -s <shutport>  myinst -f

    Regards,

    Irfan

  • I added 'oemanager' folder and started server oepas1. Dev Studio displayed message SportsService (Mobile Service) was published but I couldn't display http://localhost:8810/Sports/rest/SportsService/Customer and http://localhost:8810/Sports/static/mobile/SportsService.json in Chrome - web pages are unavailable. I can see 'static/mobile/SportsService.json' file' in 'webapps/Sports' folder but there is no 'rest' folder in it.

  • The "rest" folder should  be displayed in WEB-INF/adapters

    Regards,

    Irfan

  • What is the HTTP response you're getting when going to those pages? (404 / 403 / etc.)

    It could also be useful to include PAS logs like the localhost access log and catalina log.

  • In fact I can see it but test Sports Service on the browser fails.

  • localhost_access_log.2015-08-19.txt

    Browser displays "Can't display page" message. Could you help me with finding logs ?

  • You will have the logs in your instance logs location

    oepas1/logs/

    Logs to look for would be localhost_access* and any exception related logs in catalina or oepas1.*.log

    Regards,

    Irfan

  • catalina.2015-08-19.log

    Here is catalina log and localhost in previous message. I can't add 2 files at once.

  • Your log says that your application is deployed in oepas1 whose http_port is 8080, but the URL you were trying to access was "8810".  Seems like your application is started with "8080" and you should access your service using that port for oepas1 instance

    Regards,

    Irfan

  • Indeed default port numbers are 8080 and 443 (https) unless you define -p (http) and -P (https) when creating a new instance. 

    Well at least you have a basic understanding now ;)

    Sent from my iPhone

    On 19 Aug 2015, at 21:21, Irfan <bounce-isyed@community.progress.com> wrote:

    Reply by Irfan

    Your log says that your application is deployed in oepas1 whose http_port is 8080, but the URL you were trying to access was "8810".  Seems like your application is started with "8080" and you should access your service using that port for oepas1 instance

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.

  • You are great, thank you - untill next question :)