Creating An SSL SonicMQ 8.0 End Point - Forum - Community Groups - Progress Community

Creating An SSL SonicMQ 8.0 End Point

 Forum

Creating An SSL SonicMQ 8.0 End Point

This question is not answered

Hi All,

This might not be discussed any more, but I'm running out of ideas. We use Sonic ESB for mobility intergation with PDA type devices but now have a request to make the end point secure with SSL.

All the documentation and white papers I've found always seem to exclude one configuration point which i believe will get me through. Problem is I'm not exactly sure what it is.

What we have currently is an existing URL end point that accepts connections (RESTful POST/GET) and a secondary URL on a different port which we configure as being SSL.

We have a legitimate certificate issued by GeoTrust, the Intermediate CA and the Root CA. I've followed the documentation that I've found and appears to have configured correctly. But any SSL connection attempt fails.

Can someone point me in the right direction on configuring an SSL acceptor in Sonic?

Thanks,

Tony.

All Replies
  • Hi Tony,

    Can you please provide us the error that you observed while you are establishing SSL connection and relevant log files?

    Also can you provide us your configuration (that includes each hop (SSL enabled or not))?

    Example:

    ABL client application (SSL enabled) --- connecting to AppServer (SSL enabled) -- connecting to DB (SSL not enabled)

    Thanks,

    Srinivas Munigala

  • CMSAProd.MsgContainer.zipHi Srinivas,

    The client is not ABL in this case. It will either be from an Android app or iPhone app.

    Either app will do a Restful post to the exposed URL. Below is the acceptor configuration I'm trying to use.

    Here is the broker log with the errors when trying to post to it.

    CMSAProd.MsgContainer.zip

  • Hi Tony,

    Thanks for the information. After looking into the details, I feel that Aurea would be the right candidate to help you on this. So please contact Aurea Support (http://www.aurea.com/support) to get it resolved.

    Thanks,

    Srinivas Munigala