Hey,


I am sending a request with the SOAP header parameters with https progress 10.2b . However, permanent return value gives me error . I could not figure out the problem . Can you help me.

Request:

<soap-env:Envelope xmlns:pos="bird.kartaca.com/.../pos" xmlns:soap-env="schemas.xmlsoap.org/.../">
<soap-env:Header>
<wsse:Security soap-env:mustUnderstand="1" xmlns:wsse="docs.oasis-open.org/.../oasis-200401-wss-wssecurity-secext-1.0.xsd" xmlns:wsu="docs.oasis-open.org/.../oasis-200401-wss-wssecurity-utility-1.0.xsd">
<wsse:UsernameToken>
<wsse:Username>joker_pos</wsse:Username>
<wsse:Password Type="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#PasswordText">j112233</wsse:Password>
</wsse:UsernameToken>
</wsse:Security>
</soap-env:Header>
<soap-env:Body>
<pos:GetBirdUserInfoRequest>
<pos:storeCode>joker1</pos:storeCode>
<pos:token>8616 0985 22</pos:token>
</pos:GetBirdUserInfoRequest>
</soap-env:Body>
</soap-env:Envelope>

Result:

Fault Code : Sender
Fault String: INVALID_REQUEST - Request is not valid for XSD rules.
Fault Actor :
Error Type : SOAP-FAULT
Fault Detail:
<?xml version="1.0" ?>
<detail xmlns:SOAP-ENV="schemas.xmlsoap.org/.../"><ServiceError xmlns="bird.kartaca.com/.../ServiceError><description>Request is not valid for XSD rules.</description><details>cvc-complex-type.2.4.a: Invalid content was found starting with element 'soap-env:Header'. One of '{"bird.kartaca.com/.../pos":licenceKey, "bird.kartaca.com/.../pos":merchantCode, "bird.kartaca.com/.../pos":storeCode}' is expected.</details></detail>