I am using the Openedge client to communitcate with our Openedge 10.1B database in a .Net Web application.

Everything works just fine on my PC:

     OS: XP SP3

     Running through VS 2010 debugger.

However, when I try to install it on the webserver running under MSServer 2008 I get the following error:

     Could not load file or assembly 'Progress.ssl.DLL' or one of its dependencies.  is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)

Webserver is:

     OS: MSServer 2008 64bit

I have already done the following:

  1. I ran Dependancy Walker and found that it was missing IEShims.dll, gpsvc.dll and sysntfy.dll. 
    1. I found those files and copied them to the web application bin directory.
  2. Dependancy Walker complained that there was a mix of 32 and 64 bit programs (Open edge is 32 bit).
    1. I located the 32 bit version of IEShims.dll, gpsvc.dll and sysntfy.dll from a 32 bit install on another machine and replaced the copies in the Webapplication bin directory.
  3. Dependancy Walker is still giving a warning of: "Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module."
    1. As near as I can tell this is on the IEShims.dll file and everything I can find via Google says this should be ok.

However, I still get the error on the Progress.ssl.dll when I try to access the Web Application.

Has anyone else tried this and run into this problem or have a further clue as to what I am missing or doing wrong?

Thanks.