ProLint in OpenEdge 11.5 (64 bit) - Forum - Community Groups - Progress Community

ProLint in OpenEdge 11.5 (64 bit)

 Forum

ProLint in OpenEdge 11.5 (64 bit)

This question is answered

Hi All,

I've managed to get prolint running on a 10.2B version of Progress but when I follow the exact same instructions and apply it to my 11.5 version of OpenEdge it falls over with "Could not find class or interface org.prorefactor.core.JPNode (12886)."  The only major difference between them (other than the version!) is that I run prowin32.exe on version 10.2B and prowin.exe on 11.5.  Is there a different version of the proparse dlls for 64 bit systems?  Am I missing something obvious?

Thanks,

Mark

Verified Answer
  • We started extending proparse a while ago and added also new keywords. The new version definitively works on 11.5 – 64 bit as well.
     
    Download
    from:
     
     
    Assemblies:
     
    <assembly name="IKVM.OpenJDK.Core, Version=7.2.4630.5, Culture=neutral, PublicKeyToken=13235d27fcbfff58"/>
    <assembly name="IKVM.Runtime, Version=7.2.4630.5, Culture=neutral, PublicKeyToken=13235d27fcbfff58"/>
    <assembly name="proparse.net, Version=4.0.1.1114, Culture=neutral, PublicKeyToken=cda1b098b1034b24"/>
     
    The git repository contains the binaries of the assemblies as well. Proparse in the root folder, IKVM in the ikvmbin folder.
     
    Absolutely no warranties!
     

    Architect of the SmartComponent Library and WinKit

    Consultingwerk Ltd.

All Replies