Problem to generate model (edmx) from VS 2012 for DB2 on Z/OS - Forum - DataDirect Connect - Progress Community

Problem to generate model (edmx) from VS 2012 for DB2 on Z/OS

 Forum

Problem to generate model (edmx) from VS 2012 for DB2 on Z/OS

This question is answered

Hi,

I'm facing a problem during testing the ADO.Net provider for DB2 on Z/OS.

I'm using Visual Studio 2012 and a trial of the ADO.Net provider 4.2 from Progress as you can see : 

On a new project, i'm trying to generate a model from the Database using EntityFramework but i have problems.

Here is the steps I did :

- Right-click on the fresh project

- Add a new file

- I select ADO.NET Entity Data Model and click to Add

- Then i select "EF Designer from a database"

- I create a new connection, and testing it works fine (bind packages are done etc.)

- I include sensitive information on the ConnectionString and I clic on next and then...

In english "Your project references the latest version of Entity Framework; however, an Entity Framework database provider compatible with this version could not be found for you data connection. Exit this wizard, install a compatible provider, and rebuild your project before performing this action"

I have the same error installing EntityFramework 6.0.0, 6.0.2, 6.1.3

I tried to install EF 5.0 and I have this screen : 

In english "Your project references an older version of Entity Framework. To use the latest version, exit this wizard andupgrade before performing this action"

Can you please help me to solve this ?

I'm on this problem from days and now i have no idea to do.. I tried on x64, x86, Any CPU..

Thanks

Regards

Verified Answer
  • Hi,

    Thanks for trying our provider. Our Connect for ADO.NET DB2 Entity provider is supported only with DB2 for i.

    Currently we do not have DB2 entity provider supported with Z/OS. Please create an idea for same.

    Thanks,

All Replies
  • Hi,

    Thanks for trying our provider. Our Connect for ADO.NET DB2 Entity provider is supported only with DB2 for i.

    Currently we do not have DB2 entity provider supported with Z/OS. Please create an idea for same.

    Thanks,

  • Hi, thanks for your reply.

    But why in the documentation and in your website www.progress.com/.../ibm-db2

    We can read "DB2 V10.1 for z/OS" ? Is it a mistake ?

    Regards

  • Oh I saw what's wrong...

    Progress DataDirect Connect for ADO.NET Entity Framework Version 4.2.0, there is only DB2 for i but for Progress DataDirect Connect for ADO.Net Version 4.2.0 (so no EF) there is DB2 for Z/OS...

    Thanks again.

  • Hi,
     
    Progress DataDirect Connect for ADO.NET” section talks about data provider support matrix. Our ADO.NET provider supports "DB2 V10.1 for z/OS".
     
    EntityFramework provider support is listed under “Progress DataDirect Connect for ADO.NET Entity Framework” section.
    Thanks