Login to Dynamics CRM - Forum - DataDirect Cloud - Progress Community
 Forum

Login to Dynamics CRM

  • Hi,

    I am currently evaluating the data direct cloud for Dynamics CRM connectivity.

    I tried to create a data source but geta connection error.

    I tried both CRM Online & Prtner Hosted service but get errors on both.

    Connection error to CRM Online:

    [d2c][JDBC Cloud driver][Dynamics CRM]The configuration options used to open the database do not match the options used to create the database.

    Connection error to partner hosted service:

    [d2c][JDBC Cloud driver][Dynamics CRM]Authentication Failure

    Does anyone has a clue how to solve this error?

    Thanks in Advance,

    Orna.

  • Try setting Create Mapping to Force New.  This setting is on the Advanced tab of the Dynamics datasource you created in the web interface.

  • Hi,

    After changing this setting, I still get the following error:

     [d2c][JDBC Cloud driver][Dynamics CRM]Authentication Failure

    Orna

  • Hi Orna,

    Are you using Office 365 login credentials to connect to Dynamics?

    Regards,
    Rashmi

  • I am using crm login credentials.

    my user id is: benari@benariorna.onmicrosoft.com

    Orna.

  • Orna,

    I get the Authentication Failure error when an incorrect password is specified during connection. Can you re-enter your correct password and test connect?

    ~ Rashmi

  • I am positive 100% I am putting the right user and password.

    I use other tools to connect to Dynamics and I dont have any problems.

    Orna.

  • Orna,

    Can you include the Organisation Service URL you are connecting to and the last time you tried to test connect?

    ~ Rashmi

  • Are you part of the data direct support team?

    If yes, please send me your email and I will send you the URL by mail.

    Orna.

  • Ben, the URL and login you sent directly to us off the forum look correct compared to our test credentials.

    Here is a working combination for example:

    Org URL: https://vembar.api.crm.dynamics.com/XRMServices/2011/Organization.svc

    Office 365 Login: rashmivembar@vembar.onmicrosoft.com

    We are investigating and will post the next step to resolve.

    Check out my world famous blog on data connectivity

  • We have confirmed your account is authenticating as Office 365 which is supported. 

    The remaining difference between our accounts is that we are connecting to Dynamics CRM Online in North America whereas you are connecting in EMEA.  We are looking to test from DataDirect offices in EMEA as the next step.

    Check out my world famous blog on data connectivity

  • We were able to repeat the isue by creating a new Office 365 account and setting the country as Israel. We are looking into this.

    Check out my world famous blog on data connectivity

  • This issue is no longer reproducing with the current deployment of DataDirect Cloud

  • Hi,

    I'm currently facing similar issue, with with a different outcome: I'm trying to connect with my trial account in Dynamics CRM, but when I test the connection, I get one of 2 errors:

    "Your request has been timed out, could you try after some time."

    or:

    [d2c][JDBC Cloud driver]Communication failure. Unexpected HTTP status code: 504 GATEWAY_TIMEOUT

    I've verified multiple times the connection configuration:

     - User Id: <my_test>@<my_test>.onmicrosoft.com

     - Organization Service URL: https://<my_test>.api.crm4.dynamics.com/XRMServices/2011/Organization.svc

     

    Any clues?

    Thanks in advance,

    Karol

     

  • Hi Karol,

    From the URL, your organization service is hosted at the crm4 datacenter, which is located in the EMEA region.  There is a known issue for connecting with different regions, where you could see "An error occurred while verifying security for the message'.  There is a fix for this issue, which is currently being tested in-house.

    However, looking at the logs for your connection attempts, the error you're getting is:

    Authentication Failure: The specified member name is either invalid or empty.

    This wouldn't be related to the issue I mentioned previously.  Some suggested reasons for the 'authentication failure' error that your connections are experiencing are:

    - the user in question does have sufficient privileges.  You can test by using an admin account to log in, and see if the behavior changes)

    - the credentials are an older format and were not updated / converted correctly for Office 365.  You can check with your IT about the Office 365 credentials being used, or if the user name has been changed and an old cached value needs to be flushed, etc.  Here's a post relating to this occurrence:

    blogs.technet.com/.../adfs-logon-issue-quot-your-organization-could-not-sign-you-into-the-service-quot-0x80041034.aspx

    If you can, check on the user settings / credentials, and let us know if anything has changed since they were initially created.