ddc on premise connector - Forum - DataDirect Cloud - Progress Community
 Forum

ddc on premise connector

  • Hi all,

    I had installed on-premise connector for public cloud rollbase a month ago to connect to data store through data direct cloud. After a month my data direct cloud expires. Now today Again i created a login credential on data direct cloud. For this I had to uninstall the previous on-premise connector and again i reinstalled on premise connector with the new login credential of data direct cloud. My question is When i install new on-premise connector and check the configuration for Status tab and click on test then  a red cross appears on Cloud connector Service. Service DDcloudOpCon is running failed.

    PROGRESS_DATADIRECT_CLOUD_OPCONNECTOR_3.0_WIN_64_INSTALL

    ddc.doc

    Please suggest what can be the possible solution.

  • The message in the attached screen shot indicates that the connector window service is running, but that server itself is not responding to the status request.  One reason that this can happen is if the server is running on the same port as another on-premise connector server on the same machine.  Check the two on-premise connectors and verify that they are running on different ports.  The port the connector is running on can be changed on the Advanced tab of the status tool.   The on-premise connector services will need to be restarted if the port number is changed.  

  • I don’t know. Would you please send me the files in \Program Files\Progress\DataDirect\Cloud_OnPremise_Connector\OPDAS\server\logs and all sub-directories? Thanks.
  • Hi,

    \Program Files\Progress\DataDirect\Cloud_OnPremise_Connector\OPDAS\server\logs  file is empty. please find attached doc. 

    onpremise.doc

    Can't we install on premise connector again after uninstalling the previous one and and reinstall on the same machine? Please i am deadly stuck on it. Please suggest. 

  • Please accept my apologies for the installation problems. Yes, you should be able to:

    * Install an on premise connector again after uninstalling the previous one.

    * Install over an existing connector.

    * Install a second (or third or fourth...) on premise connector on the same machine.

    Agreed -- this is very strange. It looks like something went wrong with the installation. Would you please send us:

    * The installation log files: \Users\<login>\DataDirect* and \Users\<login>\DDCloud*

    * The list of files in C:\Progressx86

    In the meantime I suggest trying either:

    * Uninstall, re-boot, and re-install again.

    * Or doing a second install to a new location.

    Thanks for your help.

  • Hi,

    I am still getting the same problem either if i install on premise connector to a different location/ uninstall+restart+reinstall again.

    please find the attached doc.ddc1.doc

    Please help me.

  • Are there there any installer log files -- DataDirect* or DDCloud* -- in \Users\shilpi.agarwal? If so, would you please send them to us? Thanks.

  • yes.

    aa.doc

    find 3 files. Please go through it.

    DataDirect_Cloud_On-Premise_Connector_-_64_bit.logDDCloud_OPC_install_console.log

    DDCloud_OPC_uninstall_console.log

    please suggest.

  • Thanks for the logs. They were very helpful. The On Premise Connector Installer is failing due to the installation of another Progress product. We are trying to come up with a workaround or fix to this problem.

  • Hi Jhobson,

    I am not getting this line "Installer is failing due to the "installation of another Progress product." What does it mean by another progress product? Please do clear this point so that i could also understand the problem. Thanks a lot. Atleast we got some way to find the solution.

    Thanks,

    Shilpi Agarwal

  • This is a bug in the On-Premise Connector installer.  The problem is that the CATALINA_HOME environment variable is set on the system the connector is being installed on.  The installer is recognizing that CATALINA_HOME is set and is using the value set for that variable as the base directory for the connector unfortunately this is not the correct directory for the On-Premise Connector.  We are thinking that another product that was installed on this system set the CATALINA_HOME environment variable.  We are working on fixing the installer.  In the mean time to work around this problem try the following.

    1) Examine and save the current value of the CATALINA_HOME environment variable somewhere

    2) Delete the CATALINA_HOME environment variable.

    3) Uninstall the current install of the On-Premise connector.

    4) Restart the system to insure the On-Premise connector was completely uninstalled

    5) Re-install the On-Premise connector

    6) Set the CATALINA_HOME environment variable back to its original value.

    We thinking it may have been one of our other products that may have been installed on that system and set the CATALINA_HOME environment variable.  Is Progress OpenEdge or Progress Rollbase installed on that system?

    Regards

    Mark

  • Hi,

    Yes Rollbase privtae cloud as well as Openedge 11.5 is currently installed on my system and CATALINA_HOME environmental variable is set for Rollbase private cloud.  

    Thanks for the help.

  • Have you tried Mark's work-around to the bug in the installer? If so, were you able to get a working On-Premise Connector installed?

    Thanks, John

  • Hi John,

    I have not tried Mark's Solution. Because I was not sure after mark's work applied on the system, rollbase private cloud would work correctly or not.

    Can you suggest me onpremise installer would not affect rollbase private cloud installation after CATALINA_HOME environmental variable is restored?

  • Shilpi,

    Rollbase private cloud should work after Mark's work-around, since CATALINA_HOME is restored to its original value. An additional restart may be necessary after changing CATALINA_HOME to its original value, if there are Rollbase processes that are launched at startup.

    Once installed, the On-Premise Connector does not use the CATALINA_HOME environment variable, so it won't be affected by any changes to CATALINA_HOME.

    Thanks, John