Oracle on-premise data source connection error - Forum - DataDirect Cloud - Progress Community

Oracle on-premise data source connection error


Oracle on-premise data source connection error

  • I am trying to setup a on-premise data source definition which connect to my On-premise oracle database. I have installed and configure on-premise. Generate connector-ID.

    When I click on update and test I get following error. Any help will be appreciated

    [d2c][JDBC Cloud driver][Oracle]java.lang.reflect.InvocationTargetException

  • Hi,

    I have tested this over here and I'm able to connect to the on-premise Oracle DB.
    Also, when clicking on the tab 'SQL Testing', I can successfully retrieve the schema information.

    I have tested this against an Oracle 12 db running on VM. I installed the Cloud Connector, entered my Progress ID credentials and copied the Connector-ID into my D2C datasource on the dashboard.
    I also entered :

    Can you check if you have completed the same steps and let me know to which Oracle version you're connecting as well as on which platform it is installed.

  • Sven thanks for quick response.

    I am running Oracle DB version on windows 64 bit on my local PC.

    I have entered all parameter

    1. Servername/Host name - my computer name

    2. Port number: 1521

    3. SID - My oracle db name

    4. User name  and password

    5. Connector ID - I have cut/past from on-premise configuration tool

    When I run on-premise configuration tool -> Click on Status -> Click on Test - It passes all test (all service has green check-mark)

    If I enter "

    1. Invalid user or password - It does give me invalid username/password error

    2. Invalid host name - It does give me host name error

    So looks like my setup is correct and it does talk to my local oracle DB

    Error: [d2c][JDBC Cloud driver][Oracle]java.lang.reflect.InvocationTargetException

    Is there any setup I have to on Oracle DB side?

    Is there any way I can debug Or See any log on my local machine when I run test from cloud

    Please let me know



  • Could we please get the logs from the OP Connector install? They would be located in:

    C:\Program Files\Progress\DataDirect\Cloud_OnPremise_Connector_20\OPDAS\server\logs and

    C:\Program Files\Progress\DataDirect\Cloud_OnPremise_Connector_20\OPDAS\server\logs\das.

    Thanks, John

  • I have uploaded all logs to my dropbox folder.

    Let me know if you need more info

    Thanks in advance for your help

  • Any help on this.

    I see following error inside log file under C:\Program Files\Progress\DataDirect\Cloud_OnPremise_Connector_20\OPDAS\server\logs\das

    10-Dec-2014 15:13:30.660 SEVERE [http-bio-10180-exec-45] [rhri2001][oracle][rkora11gr2_oe][zUT/s66SlsJxiIfy].[login] Exception handled:

    java.sql.SQLException: [DD Cloud OP][Oracle JDBC Driver][Oracle]ORA-01882: timezone region not found

    Log file

    10-Dec-2014 15:13:30.660 SEVERE [http-bio-10180-exec-45] [rhri2001][oracle][rkora11gr2_oe][zUT/s66SlsJxiIfy].[login] Exception handled:
        at sun.reflect.GeneratedMethodAccessor18.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at com.ddtek.cloudservice.servlets.ddn.a(Unknown Source)
        at com.ddtek.cloudservice.servlets.ddax.b(Unknown Source)
        at com.ddtek.cloudservice.servlets.CloudSql.h(Unknown Source)
        at com.ddtek.cloudservice.servlets.CloudSql.doPost(Unknown Source)
        at javax.servlet.http.HttpServlet.service(
        at javax.servlet.http.HttpServlet.service(
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(
        at org.apache.catalina.core.StandardWrapperValve.invoke(
        at org.apache.catalina.core.StandardContextValve.invoke(
        at org.apache.catalina.authenticator.AuthenticatorBase.invoke(
        at org.apache.catalina.core.StandardHostValve.invoke(
        at org.apache.catalina.valves.ErrorReportValve.invoke(
        at org.apache.catalina.valves.RemoteIpValve.invoke(
        at org.apache.catalina.valves.AccessLogValve.invoke(
        at org.apache.catalina.core.StandardEngineValve.invoke(
        at org.apache.catalina.connector.CoyoteAdapter.service(
        at org.apache.coyote.http11.AbstractHttp11Processor.process(
        at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$ Source)
        at org.apache.tomcat.util.threads.TaskThread$
        at Source)
    Caused by: java.sql.SQLException: [DD Cloud OP][Oracle JDBC Driver][Oracle]ORA-01882: timezone region not found

        at com.ddcloudop.jdbc.oraclebase.ddcr.b(Unknown Source)
        at com.ddcloudop.jdbc.oraclebase.ddcr.a(Unknown Source)
        at com.ddcloudop.jdbc.oraclebase.ddcq.b(Unknown Source)
        at com.ddcloudop.jdbc.oraclebase.ddcq.a(Unknown Source)
        at Source)
        at com.ddcloudop.jdbc.oraclebase.BaseConnection.setD2CClientTimeZone(Unknown Source)
        ... 27 more

    10-Dec-2014 15:13:30.660 SEVERE [http-bio-10180-exec-45] [rhri2001][oracle][rkora11gr2_oe][zUT/s66SlsJxiIfy].[login] exception [token=Error][errorCode=222206058][sqlState=HY000][origin=INTERNAL][message=java.lang.reflect.InvocationTargetException]
    10-Dec-2014 15:13:30.660 CONFIG [http-bio-10180-exec-45] [rhri2001][oracle][rkora11gr2_oe][zUT/s66SlsJxiIfy].[login] exception [token=Error][errorCode=222206058][sqlState=HY000][origin=UNKNOWN][message=java.lang.reflect.InvocationTargetException]
    10-Dec-2014 15:13:30.660 INFO [http-bio-10180-exec-45] [rhri2001][oracle][rkora11gr2_oe][zUT/s66SlsJxiIfy].[login] [success=false][ms=24][das ms=1][bytesIn=326][bytesOut=144][token=Login][dataSource=RKOra11gr2_OE][userID=rhri2001][password=<specified>][clientID=DD Cloud OP JDBC (][timezone=Universal][flags=5]Data Source{[Name=RKOra11gr2_OE][D2C User=rhri2001][Data Source User=][URL=jdbc:ddcloudop:oracle://localhost][Logging Level=CONFIG][Log Privacy=ALLOWNONE]Properties{[user=oe][clientTimezone=Universal][ConnectionRetryCount=0][ServerName=RKSHAH-DT.AMER.CORP.NATINST.COM][SID=Ora11gr2]}}[internalConnect=0]
    10-Dec-2014 18:41:47.857 SEVERE [http-bio-10180-exec-1] [rhri2001][oracle][rkora11gr2_oe][D5uQFBGKm7gF5Qrq].[login] Exception handled:




  • Hi,

    We are still investigating your issue and I will update you as soon as I have more info.

    Kind regards,
  • RK,

    Sorry for the delay in getting back to you and thanks for the logs. I found the same error you found. I've reproduced the problem. It's a bug for which we do not have a work-around. However, your data source will work when used with either the D2C JDBC or D2C ODBC driver.


  • By the way, I forgot to mention that this is only a problem with an Oracle data source.


  • Thanks John

    Please let me know when you have a fix for this.

    I did install Oracle database r12c and it work with r12c. But I am working on POC for and on-premise Oracle ERP system integration with SalesForce external object using DataDirect on-premise. Our Oracle ERP system is Oracle DB 11g and inside the firewall.



  • Hi RK,

    I have created defect PSC00323514 to get this fixed.

    Kind regards,
  • RK,

    Yes, Oracle servers less than version 12 don't appear to support the Universal time zone.

    Thanks, John

  • As of the DataDirect Cloud deployment on Jan 29, 2015  this issue has been fixed.  If the Oracle data source in use is an on-premise data source, the latest On-Premise connector will need to be downloaded and installed.  See the release notes at

    for instructions on updating the On-Premise Connector