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INTRODUCTION
This document explains how to call ABL business logic running in an OpenEdge
AppServer from a Rollbase application. External references are made to sections of
the documentation of each product and the reader should be aware that some
details may vary in other versions of the products.
This paper shows by means of a sample the integration between an on-premise
installation of OpenEdge and Rollbase - that means you are not using a hosted
solution and have the software running on servers under your control. Note that the
solution described in this paper requires access to the file system and various
Rollbase configuration files, and so is not applicable to a hosted solution.
This document is aimed primarily at existing OpenEdge architects and developers,
and assumes prior knowledge of OpenEdge ABL, database and AppServer
administration.

WHAT IS PROGRESS ROLLBASE?
Progress Rollbase is a cloud platform that allows rapid creation of software as a
service (SaaS) business applications using point and click, drag and drop tools in a
standard Web browser with a minimal amount of code. Progress Rollbase can be
deployed to any cloud or in-house infrastructure.
More information about Rollbase can be found at
http://www.progress.com/products/rollbase/overview .
More information about installing and using Rollbase is available at the Rollbase
Resources page at http://www.progress.com/products/rollbase/resources , including
the comprehensive “Rollbase in Action” book. Chapter 18 of that book describes
installation and configuration.

INSTALLATION AND SETUP
INSTALL OPENEDGE
Progress OpenEdge Release 11.3 is available on Progress ESD. Download and
follow the installation instructions, making sure to install the AppServer and java
OpenClient functionality. Make a note of the install location you used. By default it
will be C:/Progress/OpenEdge. We will refer to this location as $DLC.
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INSTALL ROLLBASE
Download the latest version of Rollbase Private Cloud from the Try-It site at
http://www.progress.com/products/rollbase/try-it , and install it following the
instructions. Make a note of the install location you used. We will refer to this
location as $ROLLBASE_HOME.
Once installed, start your Rollbase Private Cloud instance.
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EXPOSE OPENEDGE APPSERVER LOGIC
This paper uses a simple example of ABL business logic coded against the
Sports2000 database, running on an AppServer.

SET UP OPENEDGE DATABASE AND APPSERVER
Before writing any code, we need to set up our environment. This document
assumes you have experience in creating an OpenEdge database and setting up an
AppServer. You must create an instance of the Sports2000 database and a
Stateless AppServer. This AppServer must connect to a Sports2000 database.
Save the ABL code in Appendix A to a file called update_department.p into a folder
that is in the Sports2000 AppServer‟s PROPATH. Make a note of this folder. Note
that the ABL code must be compiled to r-code in order to be able to generate
proxies.
Start the AppServer and verify that it is running using OpenEdge Explorer (or
another tool like Progress Developer Studio for OpenEdge (PDSOE) or the
command-line tools available via ProEnv).
You can also test that this code works as expected by running the code below from
an editor such as PDSOE. If the test succeeds you should see a message saying
„100 record updated‟.
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define variable hAppServer as handle no-undo.
define variable cStatus as character no-undo.
create server hAppServer.
hAppServer:connect('-AppService Sports2000').
run update_department.p on hAppServer (
input '100',
input 'Consulting',
output cStatus).
message
cStatus
view-as alert-box.
finally:
hAppServer:disconnect().
delete object hAppServer.
end finally.

Now that we know that the business logic is running correctly on our AppServer, we
must generate OpenClient proxies to allow Rollbase to call it. We create these proxy
objects using a tool called the Proxy Generator, accessible via the Start Menu. There
is a 3-step process to this:
>

First, we generate the Java classes,

>

Second, we package them into a Java archive (“jar”), and

>

Finally, we deploy the necessary jars into Rollbase.

GENERATE JAVA OPENCLIENT PROXY CODE
To generate the Java classes, we run the Proxy Generator from the Start Menu and
select File > New to create a new AppObject. The screen should look like the
screenshot below.
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Change the name of the AppObject to Sports2000. Now, using the New … button,
add the Propath component; this will be the folder into which you saved the
update_department.p procedure.

Now select the Procedures tab and add the update_department procedure. Rightclick in the Non-persistent Procedures editor and select Add > Non-persistent
from the context menu as per the screenshot below. Navigate to the folder and
select the r-code for the update_department procedure. Note that the ABL code
must be compiled to r-code in order to be able to generate proxies.
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Now we can generate the proxy code, using the File > Generate menu option.

Setting name

Value

Comment

Client Type

Java

Package

samples.sports2000

You can provide
any package
name

Output Directory

<any temporary
location>

Mandatory
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Setting name

Value

Comment

AppService
Name

<use default>

You can
optionally change
this value to
another
AppServer‟s
name but in our
case we will use
the default value

Select OK to start the generation. You will be prompted for a location to save the
Sports2000.xpxg file; you can select any location.
A message indicating success or failure will appear once the proxy generation is
complete.

PACKAGE JAVA OPENCLIENT PROXY CODE
Before the OpenClient proxies can be deployed into Rollbase, we need to package
them into a Java Archive (jar) file.
There are many ways of doing this, but the simplest way is via the command-line.
From the Start Menu, run Proenv.
Change directory to the Output Directory you specified in the Generator
cd C:\My\Output\Directory

Now use the jar command to create the archive file. It can be named anything you
want; we‟ll call it sports2000.jar .
%dlc%\jdk\bin\jar.exe -cvf C:\My\Output\Directory\sports2000.jar
samples\sports2000\*.class

DEPLOY OPENEDGE FILES TO ROLLBASE
In order for Rollbase to be able to access to OpenEdge AppServer, we need to add
some files to the Rollbase install. These files fall into 2 categories: firstly, there are

9

the files that allow Rollbase to connect to the AppServer, and secondly, the files that
represent the ABL business logic.
Copy the connection files from the $DLC/java folder into the Rollbase Tomcat lib
folder (Rollbase runs within Tomcat).
>

o4glrt.jar

>

progress.jar

Copy the Sports2000 business logic jar file from the generated location into the
same folder.
>

sports2000.jar

We also need to tell Rollbase that we intend to use these custom classes. Using a
text editor, open the shared.properties file which is located in the
$ROLLBASE_HOME/config folder, and add the following line.
# OpenClient packages
CustomClassFilter=(com\.progress\.open4gl\..*)|(samples\.sports2000\..*)

If you used a different package name in the Generator settings, replace the
CustomClassFilter value. This filter allows us to call classes in the
samples.sports2000 package (our AppServer-calling code) and the
com.progress.open4gl package (some OpenEdge-provided utilities).
Note that this value is treated as a regular expression (regex) and some can become
quite complex. For now, our simple filter will suffice. Save your changes and restart
your Rollbase server.
At this point we have our ABL business logic running and exposed to Rollbase via
the Java OpenClient. We will now create a Rollbase application and call this ABL
business logic.
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CALL OPENEDGE APPSERVER LOGIC FROM
ROLLBASE APPLICATION
We will install and modify one of the provided Rollbase applications and call our
deployed ABL business logic from there.
Select the Organization Management application from the Applications dropdown
on the upper left-hand-side. If this application is not available, add it to Rollbase via
the Find Apps button under the dropdown.
We now need to modify the Department Object. To do so, select the Departments
tab followed by the tab menu dropdown (see below). Select the Object Definition
option.
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We now create a trigger which calls the ABL business logic. From the Object View
page, scroll down to the Triggers section or jump there via the Triggers link in the
grey header section. Select New Trigger, choose the Object Script option near the
end of the list, and click Next.
We first need to decide when this trigger is to be fired, in the Trigger Timing section.
Chapter 10 has a section on Order of Execution which illustrates the order in which
triggers are fired in Rollbase. For this trigger, make sure that the After Create and
After Update options are checked. This means that any time the values in the
Department object change the trigger will fire.
Give the trigger a name - Update ABL Department will do fine – and copy and
paste the code from Appendix B – Rollbase Trigger Code into the empty editor in
the Trigger Properties section. Select Save to complete the trigger.

OBJECT SCRIPT OVERVIEW
The trigger script is relatively simple in what it aims to achieve, via 3 main pieces of
functionality: get values from Rollbase, pass those values to OpenEdge and finally
create an activity/audit record containing a status message.
To get values from the Rollbase Department record, we use the getFieldValue API
for this. In the snippet below, we retrieve the department code and name from the
Department object and store them in two variables. The $ORG_DEPT token
represents the Integration Name for the Department object. The {!id} token
represents the current user session.
// Get the values from Rollbase
var deptCode=rbv_api.getFieldValue("$ORG_DEPT", {!id}, "deptCode");
var deptName=rbv_api.getFieldValue("$ORG_DEPT", {!id}, "name");

Chapter 6 in the Rollbase in Action book has more details of the API.
We now need to pass those values into the OpenEdge part of the application. To do
this, we connect to an AppServer, pass it the values and disconnect when done. The
instantiation of the Sports2000 class in the line starting var 2sk = new takes as the
first argument the connection for the AppServer we set up earlier.
The call to s2k.update_department passes in the values we retrieved from
Rollbase, together with an (empty) StringHolder1, which also contain the output
parameter value, as returned by the ABL update_department.p code that runs on
the AppServer.

1

The StringHolder class is a utility class provided by the OpenEdge Open Client which allows us to pass character (string) values by reference. It is
an INPUT-OUTPUT parameter in ABL terms.
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Finally, per the OpenEdge documentation, we call _release() to disconnect from the
AppServer since we‟re done with this connection.
var status = new Packages.com.progress.open4gl.StringHolder();
var s2k = new Packages.samples.sports2000.Sports2000
("AppServer://localhost:5162/Sports2000", "","", "");
// Pass the values to ABL and retrieve the status
s2k.update_department(deptCode, deptName, status);
// Disconnect from the AppServer
s2k._release();

We now have the results of our ABL business logic call in the status variable. While
the functional part of calling the AppServer is now done, we would like to make a
note of the fact that the Rollbase Department object modified something else. To do
so we create an activity (or audit) record using the createActivityLog() API. Once
again more detail on the API is available in Chapter 6 of the Rollbase in Action book.
// Create an activity/audit record
rbv_api.createActivityLog("$ORG_DEPT", {!id}, "OE AppServer Status: " +
status.getStringValue());

EXAMPLE IN ACTION
Now that we‟ve put all the parts together, let‟s take a look at an example in action.
We will create a new Department record. Make sure you are in the Organization
Management application (dropdown in the top left corner). Select one of the New
Department buttons (either will do) and add a new department. Use any values for
the Department (name) and Department Code fields. In the screenshots below, we
used People Operations as the Department name and POP as the Department
Code. The other values are optioanl. Select Save when done.
You should be returned to the Departments tab, with its tree and list of departments.
Select (for editing) your newly-created department. Now select the System Info tab
and note the audit trail which has a status item created by the Object Script trigger
containing data the ABL call.
This is illustrated in the screenshot below.
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CONCLUSION
This document set out to show how to invoke ABL business logic running on an
OpenEdge AppServer directly from a Rollbase private cloud installation. The
example above illustrates the ease with which this can be done, providing access to
a wide range of ABL business logic via Rollbase‟s event triggers.
This functionality may be particularly useful for Rollbase private cloud installations
that would like to provide access to ABL application business logic that may already
exist at a site. The Java OpenClient toolkit is available in supported versions of
OpenEdge.
More generally, the private cloud installation of Rollbase can be extended with your
own libraries of Java classes. For more information, see the Custom Java
Development Toolkit (available from Private Cloud Downloads portal). This contains
documentation and examples for building custom Java-based triggers, batch jobs
and JSPs.
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APPENDIX A: ABL APPSERVER CODE

/*-----------------------------------------------------------------------File
: update_department.p
Notes
: Updates or creates a Department record.
----------------------------------------------------------------------*/
block-level on error undo, throw.
define input parameter pcDeptCode as character no-undo.
define input parameter pcDeptName as character no-undo.
define output parameter pcStatus as character no-undo.
/* Shows values passed in */
message 'Dept Code: ' pcDeptCode.
message 'Dept Name: ' pcDeptName.
find Department where
Department.DeptCode eq pcDeptCode
exclusive-lock no-wait no-error.
if not available Department then
do:
create Department.
assign Department.DeptCode = pcDeptCode
Department.DeptName = pcDeptName
pcStatus = pcDeptCode + ' record created'.
end.
else if locked Department then
pcStatus = pcDeptCode + ' record locked - try again later'.
else
assign Department.DeptName = pcDeptName
pcStatus = pcDeptCode + ' record updated'.
return.
catch ae as Progress.Lang.AppError :
pcStatus = 'ERROR: ' + ae:ReturnValue.
end catch.
catch e as Progress.Lang.Error :
pcStatus = 'ERROR: ' + e:GetMessage(1).
end catch.
finally:
message 'Status: ' + pcStatus.
end finally.
/** eof **/
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APPENDIX B: ROLLBASE TRIGGER CODE

// Get the values from Rollbase
var deptCode=rbv_api.getFieldValue("$ORG_DEPT", {!id}, "deptCode");
var deptName=rbv_api.getFieldValue("$ORG_DEPT", {!id}, "name");
var status = new Packages.com.progress.open4gl.StringHolder();
var s2k = new Packages.samples.sports2000.Sports2000
("AppServer://localhost:5162/Sports2000", "","", "");
// Pass the values to ABL and retrieve the status
s2k.update_department(deptCode, deptName, status);
// Disconnect from the AppServer
s2k._release();
// Create an activity/audit record
rbv_api.createActivityLog("$ORG_DEPT", {!id}, "OE AppServer Status: " +
status.getStringValue());

Progress Software
Progress Software Corporation (NASDAQ: PRGS) is a global software company that simplifies the development, deployment and
management of business applications on-premise or in the cloud, on any platform or device, to any data source, with enhanced performance,
minimal IT complexity and low total cost of ownership.
Worldwide Headquarters
Progress Software Corporation, 14 Oak Park, Bedford, MA 01730 USA
Tel: +1 781 280-4000 Fax: +1 781 280-4095 On the Web at: www.progress.com
Find us on facebook.com/progresssw twitter.com/progresssw youtube.com/progresssw
For regional international office locations and contact information, please refer to the Web page below: www.progress.com/worldwide
Progress, [ALL PRODUCT NAMES LISTED IN PUBLICATION] are trademarks or registered trademarks of Progress Software Corporation
or one of its affiliates or subsidiaries in the U.S. and other countries. Any other marks contained herein may be trademarks of their respective
owners. Specifications subject to change without notice.
© 2013 Progress Software Corporation and/or its subsidiaries or affiliates. All rights reserved.
Rev. MO/YR

