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Error 290 with Progress clients using Windows 2000 TS SP3 or SP4 with application deployed on a network drive

Information

 
TitleError 290 with Progress clients using Windows 2000 TS SP3 or SP4 with application deployed on a network drive
URL NameP47046
Article Number000172026
EnvironmentWindows 2000
Citrix MetaFrame (for Windows 2000 Terminal Server)
Citrix WinFrame
Windows 2000 Advanced Server
Windows 2003
Windows XP
Question/Problem Description
Intermittent client disconnects with error 290
SYSTEM ERROR: I/O error <n> in <program>, ret <n>, file <n>, addr <n>. (290)
SYSTEM ERROR: I/O error 22 in readit, ret -1, file <n>, addr 0. (290)
I/O Errors on Windows 2000 Terminal Services / Metaframe
client server application
Progress application files are stored on a network drive
Windows and Citrix have the latest patches and Service Packs applied
No hardware issue on the client system
Error 290 with readit error 22 when starting application
Windows 2000 SP3 or SP4 installed
Steps to Reproduce
Clarifying Information
Error Message
Defect Number
Enhancement Number
Cause
This is a known Microsoft issue with Windows 2000 using mapped drives and network shares. Users running programs from Network shares or mapped drives may see programs close or generate errors when another Terminal Services user logs out of the session.

For further information please take a look at the following MS Knowledge Base documents:
http://support.microsoft.com/?kbid=294816
http://support.microsoft.com/?kbid=818528
http://support.microsoft.com/?kbid=299603
Resolution
Option 1: Disable opportunistic locking on the Windows 2000 Server.

For information on how to Configuring Opportunistic Locking in Windows
please see: Microsoft Knowledge Base Article - 296264

Option 2: Move the Progress application files locally to the TS / Citrix server.
Workaround
Notes
Hardware issues (network interface, RAM) have been reported to cause similar symptoms. The hardware should be troubleshooted as well if the issue occurs although the Microsoft issue has been solved.
References to written documentation.

Progress Solution, P2931 - (290) error on Progress clients using Windows Terminal Server and/or Citrix Metaframe
Progress Solution, P11116 - Error 290 on Progress clients using Windows 2000 Terminal Server SP3 or SP4 with the temporary directory pointing to a network drive
Keyword Phrase
Last Modified Date9/13/2015 3:06 PM

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