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(290) error on Progress clients using Windows Terminal Server and/or Citrix Metaframe

Information

 
Title(290) error on Progress clients using Windows Terminal Server and/or Citrix Metaframe
URL NameP2931
Article Number000128489
EnvironmentProduct: OpenEdge
Version 10.x, 11.x
Product: Progress
Version: 9.x
OS: Windows NT 4.0 Terminal Server Edition, Windows 2000
Other: Citrix MetaFrame (for Windows 2000 Terminal Server), Citrix MetaFrame (for Windows NT 4.0 Terminal Server)
Question/Problem Description
Intermittent Progress client disconnection using Terminal Server and or MetaFrame
SYSTEM ERROR: I/O error n in program, ret n, file n, addr n. (290)
SYSTEM ERROR: I/O error 22 in readit, ret -1, file 7, addr 0. (290)
Application files or executables located on file server on Terminal Server or Citrix machine.
No hardware issue on the server system
Steps to Reproduce
Clarifying Information
Error Message
Defect Number
Enhancement Number
Cause
This was caused by a known Microsoft Bug:
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q272582

This problem can be caused when the user that first opened the shared file logs off. The Terminal Server incorrectly closes the file handles that it has open to the remote file, so any other programs that had the file open are no longer able to access the file. Note that this problem does not occur if the data files are moved to a local volume on the Terminal Server.
Resolution
Fixed in Service Pack 3 of Windows 2000
Workaround
Notes
Hardware issues (network interface, RAM) have been reported to cause similar symptoms. The hardware should be troubleshooted as well if the issue occurs although the Microsoft issue has been solved.
It has not been confirmed that the Microsoft Service Pack 3 fixes all instances of this problem.

References to written documentation.

Progress Solution, P11116 - Error 290 on Progress clients using Windows 2000 Terminal Server SP3 or SP4 with the temporary directory pointing to a network drive
Progress Solution, P47046 - Error 290 with Progress clients using Windows 2000 TS SP3 or SP4 with application deployed on a network drive
Keyword Phrase
Last Modified Date9/13/2015 3:31 AM

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