Salesforce

OE Architect application fails to connect to the database with error 748

« Go Back

Information

 
TitleOE Architect application fails to connect to the database with error 748
URL NameP138520
Article Number000135765
EnvironmentProduct: OpenEdge
Version: 10.2x, 11.x
OS: Windows
Question/Problem Description
Getting an error when trying to run a procedure in OpenEdge Architect.
Getting error "(748) The server or system has no more resources".
Two of the databases are connected, one is configured with the maximum number of servers parameter set to 1.
Steps to Reproduce
Clarifying Information
Error Message
Defect Number
Enhancement Number
Cause
When OpenEdge Architect runs, it connects to the databases as a SQL client, causing the database Broker to spawn a SQL server (_sqlsrv2) process.
The database broker is unable to spawn another server for the ABL/4GL client running the application in OpenEdge Architect because the maximum number of servers parameter is set to 1.  For further discussion on OpenEdge Architect database connections, refer to Article  Error 748 when launching application from OpenEdge Architect   
Resolution
Increase the maximum number of servers (-Mn) database parameter to allow the Login Broker to spawn servers for both SQL and ABL/4GL remote clients.
Refer to Article  How to set the values for the startup parameters -Ma, -Mn and -n    
Workaround
Notes
Keyword Phrase
Last Modified Date11/20/2020 7:37 AM

Powered by