Salesforce

ODBC driver is not available after installing SQL Client Access

« Go Back

Information

 
TitleODBC driver is not available after installing SQL Client Access
URL NameP125496
Article Number000130083
EnvironmentProduct: OpenEdge
Version: 10.x, 11.x
OS: Windows
Other: Installation
Question/Problem Description
Progress OpenEdge 10.x ODBC driver is not listed in ODBC Data Source Administrator Driver tab.
ODBC driver is not shown in the 32-bit and 64-bit ODBC Data Source Administrator (odbcad32.exe).
ODBC .DLLs (pgoe10XX.dll, pgoe10XXr.dll, etc.) are not present in %DLC%\bin where "XX" is 2 digit numeric number.
ODBC driver files (e.g. pgoe1024.dll) are not present in <OpenEdge InstallDir>\installd.ini.
Steps to Reproduce
Clarifying Information
SQL Client Access product has been installed.
Custom installation Option was selected.

ProCfg101x.log from ProInventory utility contains:
[Installed Products]
ProductCount=1
Product 129=OE SQL Client Access (1 USERS)

[Product 129]
_Component_Common Files (m)=1
__SubComponent_Common Files (m)=1
__SubComponent_WebSpeed Common (m)=1
_Component_Name Server (m)=1
_Component_OpenEdge SQL ODBC Clients=0
__SubComponent_SQL Common (m)=0
__SubComponent_SQL ODBC Client (m)=0
__SubComponent_SQL Server (m)=0
__SubComponent_Database Tools (m)=0
__SubComponent_ICU PSC (m)=0
_Component_OpenEdge SQL JDBC Clients=0
__SubComponent_SQL JDBC Client (m)=0
_Component_OpenEdge ESQL/C Clients=0
__SubComponent_ESQL Client (m)=0
_Component_Secure Clients (m)=1
__SubComponent_Client-Side Security (r)=1
__SubComponent_Perl (m)=1
__SubComponent_Security Common (m)=1

Entry in <OpenEdge InstallDir>\installd.ini file for SQL Client Access components shows same as ProCfgxxx.log from proinventory
Error Message
Defect Number
Enhancement Number
Cause
A custom installation was selected but the Component dialog was not. The product Components are not selected by default with a custom installation so when the installation continued only the Common Files and Secure Clients components were installed.
The 3 Optional client components were excluded:
 
_Component_OpenEdge SQL ODBC Clients=0
_Component_OpenEdge SQL JDBC Clients=0
_Component_OpenEdge ESQL/C Clients=0
Resolution
Option #1

Reinstall SQL Client Access using "Run as administrator" option on the setup.exe, select Custom installation and access the Component... dialog, available via a button on the Product List screen. Select the required components from the list and complete the installation.

Option #2
Reinstall SQL Client Access using "Run as administrator" option on the setup.exe, select a Complete installation instead. All mandatory and optional components will be installed.





 
Workaround
Notes
Keyword Phrase
Last Modified Date7/28/2016 6:53 AM

Powered by