Networking Problem - Forum - Progress User Groups - Progress Community

Networking Problem

 Forum

Networking Problem

  • hi.. i've encounter a problem during accessing the server.

    i have 2 client, my first client connect successfully  but the other says "table was used by username, wait or cancel"..

    anyone who can help..

    i have a screen shot of the 2 client..

    thanks in advance..

  • First, I'd rather post this to a more technical forum on this site, like http://communities.progress.com/pcom/community/psdn/openedge/abl

    hi.. i've encounter a problem during accessing the server.

    i have 2 client, my first client connect successfully  but the other says "table was used by username, wait or cancel"..

    Second, this is not a networking problem. It's a programming problem.

    Just a quick quess: Both clients are accessing the same record either in SHARE-LOCK or EXCLUSIVE-LOCK. Try changing those queries/FIND statements etc. that don't update a record to NO-LOCK.

    If you are really updating a record, you have some issues with releasing the lock on UserRecordMst (FIND CURRENT UserRecordMst NO-LOCK or RELEASE UserRecordMst) or your transaction scope. Worst case the whole users session is a single transaction because of an issue in the login screen.

  • thank you sir..

    now i know.

  • sir i got another problem..

    "event logger error 997, could not post a 'OBF_PROGRESS'"

    what do you think sir,

    i just type proserve -db obf.db -H AREKUSHISU -S 12345 to proenv.

    thanks in advance sir..

  • You should look up the error message (5180) in the Progress K-Base. But this error can safely be ignored.

    Progress isn't able to post messages to the windows event log. Usually an installtion or rights issues. Or the log may be full.

  • ok.. sir thanks again..