RTB Plug-in components - Forum - Technology Partner - Progress Community
 Forum

RTB Plug-in components

  • Does a matrix compatible component versions exist? Which component version goes with which and with which repository version?
  • Hi.

    A Compatibility Matrix exists here:

    www.roundtable-software.com/.../11.2-CompatibilityMatrix.pdf

    Please let me know if that helps or if you have more specific questions.

    Jeff

    Jeff Ledbetter
    Product Architect | Roundtable Software

  • I'm speaking of the various versions of the plug-in components, not which version of OpenEdge they are compatible with.

    For instance I updated the Roundtable TSMS SCM to v11.2.4 and get the following error: "Roundtable TSMS SCM version 11.2.4 is not compatible with RTB TSMS Server version 11.2.2" .  There have been other instances where I updated various other RTB plug-in components only to find they aren't compatible with each other.

  • Hi.

    As far as plug-in and feature components go, the latest of each should always be compatible with one-another. Sometimes older versions are compatible but if you upgrade the main feature "RTB TSMS SCM", it will fetch the latest of what it needs.

    The server component is not a plug-in but the bits running on the OE AppServer. Sometimes we have to change the server API in order to implement a feature. The plug-in know which server it is compatible with and throws up this message if you are trying to connect to an incompatible server version. We try to only change the API for major releases, but we've had to change it with patch releases a couple of times in the 11.2.x branch in order to get desired functionality.

    Most of the time if there is a new version of the plug-in features, there will be a new version of the server. You should check with your RTB administrator (who hopefully read the readme.txt file that came with the server upgrade), to see if the plug-in needs to be upgraded as well.

    Jeff

    Jeff Ledbetter
    Product Architect | Roundtable Software