500 - Internal server error when calling web services - On Premise – Configurations & Setup - On Premise – Configurations & Setup - Progress Community
 On Premise – Configurations & Setup

500 - Internal server error when calling web services

  • 500 - Internal server error when calling web services
  • Hi All,

    I'm having some trouble with a SF5 install on a new host that I'm evaluating. I see a 500 error whenever the browser makes a PUT request to a SF web service (e.g. /Sitefinity/Services/Pages/PagesService.svc

    I have added the following to my web.config file as suggested in other posts on this error

    <machineKey validationKey="249339EAFECA2359B8E0B6AB6296F7E494DD2ECE84BE33500B52CF2A57DE2EB405CCAE821A6C0B1181A8361FCB212D266B730D1E5F9546123FEAB4B3A7A9B033" decryptionKey="4CEC8E1D84ED2BA570D5E4C2E3C53E69ED7092EA8000842F751A3C9871961703" validation="SHA1" decryption="AES" />
    <trust level="Full" />

    I ran the Svc Trace Viewer on the trace file I generated, and saw this warning

    Configuration evaluation context not found
    (Open ServiceHost 'Telerik.Sitefinity.Modules.Pages.Web.Services.PagesService')

    I have asked that the hosting support team ensure the PUT verb is on for .svc services, but haven't heard back from them as of yet.

    Is there anything else I might ask the hosting support team to look for in the IIS settings to help resolve?

    Any help here would be greatly appreciated,
    Nick
  • In case anyone else has this problem, here's how I solved it :

    In order to get a better error message from IIS, I added the following to my web.config file

    <system.webServer>
        <httpErrors errorMode="Detailed"/>
        <asp scriptErrorSentToBrowser="true"/>

    This allowed me to see which handler was causing the 500 error (LiveStreamingHandler). As I'm on a shared hosting plan, I removed that particular handler (luckily I don't need to use it) by adding this to the web.config file

    <system.webServer>
        <remove name="LiveStreamingHandler"  />

    After adding that, the web services no longer return with a 500 error.

    Cheers,
    Nick