SF 5.0 deployment to Verio - On Premise – Configurations & Setup - On Premise – Configurations & Setup - Progress Community
 On Premise – Configurations & Setup

SF 5.0 deployment to Verio

  • SF 5.0 deployment to Verio
  • I am trying to deploy a new site to Verio. The client chose Verio wo/ our final blessing. It seems Verio does support ASP.NET 4.0. However the site simply doesn't come up.

    I've verified the hosting service does work with ASP.NET 4.0 WebForms by testing a very simple project.

    Also I was able to transfer my SQL data to 2005. The data passes a data comparison using VS 2010. And I modified the DataConfig.config to reference the new database.

    The client is planning to switch the URL from an existing site. So the license hasn't been set to any URL except localhost. This hasn't been an issue on our company LAN.

    Bottom line: the site doesn't respond. I get a "Request timed out" error if trying the /sitefinity/ admin url. And I recall the connection eventually gets reset if accessing the root.

    So where do I start? I don't even have any logs to read.

  • Hi,

    Firstly I want to share the following article which can guide you when deploying your project on IIS:

    www.sitefinity.com/.../installing_sitefinity_4_on_iis_7.aspx

    If you are using IIS6:

    www.sitefinity.com/.../installing_sitefinity_4_on_iis_6.aspx

    Please make sure that all the configurations are correct. Additionally, you can review the following documentation section which is also connected with deployment.

    Regards,
    Stefani Tacheva
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • I have made some progress with the Verio deployment.

    To recap, my site is developed in SF 5.0 Small Business Edition. The host is running a Verio VWS (Virtual Web Server). I don't have direct access to IIS. The admin is through a proprietary Control Panel.

    I have two specific issues at this point.

    1. The site now loads the home page. But the CSS can't be found. The site url is http://tchser.sslcert19.com/. But the primary style sheet for the first page, at tchser.sslcert19.com/.../main.css, cannot be found. The /Sitefinity/ path maps to App_Data/Sitefinity/ although I don't understand it under the hood.

    2. When I try to log into the admin site, I get the follow error trace stack:

    [ConfigurationException: Missing configuration for the requesting relying party "https://tchser.sslcert19.com"]
       Telerik.Sitefinity.Security.Claims.SWT.SWTIssuer.GetScope(IClaimsPrincipal principal, RequestSecurityToken request) +389
       Microsoft.IdentityModel.SecurityTokenService.SecurityTokenService.Issue(IClaimsPrincipal principal, RequestSecurityToken request) +74
       Telerik.Sitefinity.Security.Claims.ClaimsResolver.BuildSimpleWebToken(IClaimsPrincipal principal, String realm) +225
       Telerik.Sitefinity.Security.Claims.SecurityTokenServiceHttpHandler.SendSimpleWebToken(HttpContext context, User user, RequestMessage reqMessage) +108
       Telerik.Sitefinity.Security.Claims.SecurityTokenServiceHttpHandler.SendToken(HttpContext context, User user, RequestMessage reqMessage, String format) +112
       Telerik.Sitefinity.Security.Claims.SecurityTokenServiceHttpHandler.ProcessRequest(HttpContext context) +812
       System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +100
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +75
    
    This is my first time deploying Sitefinity to a host outside of our servers at work. I did not have these issues on our servers.
    
    I will be contacting Verio support shortly. But I am hoping someone has some insight concerning these preliminary issues.
    
    
  • Hello,

    The permissions over the App_Data folder might not be read, write, modify (full) and this prevents the css files from being read. Please make sure that you have these permissions. When in IIS the "network service" that is the user that connects to the site`s database or another user you might be using does not have full permissions over App_Data I think the anonymous user may get this problem.

    By default Sitefinity 5.x uses Claims authentication, which might be the possible reasons for the exception
    Missing configuration for the requesting relying party,
    if the authentication has not been configured properly. Can you please try switching back to Forms authentication, following the instructions on this KB article and let us know if any issues persist?

    Greetings,
    Stefani Tacheva
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items