Cannot reindex search index - General Discussions - General Discussions - Progress Community
 General Discussions

Cannot reindex search index

  • Cannot reindex search index
  • 243173_Reindex.png
    I got error when trying to reindex a search index.  I attached screen shot.

    Please help.
    Thanks.
  • Hello MJia,

    We know about this issue and we have logged a bug about it that will be fixed in our of the next builds.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • Ivan,

    I have a couple of search related questions:
    1 - When searching a site, does the search look through documents in the library?
    2 - Can you make it search through the content on documents in libraries?

    Thank you,
    Andrei
  • Hi Andrei,

    The Documents & Files module is not included in the index.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • Ivan,

    Thanks. Would you have any suggestions as to a work-around at all? Is this something Sitefinity is looking at for the future?

    Many thanks,
    Andrei
  • Hello Andrei,

    I am not able to provide you with a workaround, but we have plans to index documents and file content. We have logged task for this - ID - 106997, but currently we have not estimate it.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • I am getting this error also and therefore search does not work for me, it always is returning 0 results.  Even when i create a brand new index it doesn't seem like it is working in general.   What does the search base its results off of?  Do i need to add keywords and meta data to every single page?
  • Hello,

    Most probably the index is not configured properly. If you want to get data from pages, make sure that Static HTML checkbox is checked.

    The PagePipe looks for

    • Content
    • Keywords
    • GetFullUrl - full url
    • Description
    • Title

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • Hi,

    I am having quite the same problem when reindexing indexes.
    I get a Return 0 message or this message :
    Could not find a part of the path 'E:\web\asalogcom00\htdocs\App_Data\Sitefinity\Search\all\
    The site www.asalog.com is hosted at DiscountASP.net.
    Sitefinity version is 4.0.1098
    I have set up the scope as Static HTML and Blog Posts

    Regards
    Vincent
  • Hello Vincent,

    Please recreate your index. The error says that the files related to the index are missing.

    Could not find a part of the path 'E:\web\asalogcom00\htdocs\App_Data\Sitefinity\Search\all\

    Kind regards,
    Ivan Dimitrov
    the Telerik team
  • Hello Ivan,

    Thank you for coming back to me.

    The error message is thrown when I reindex, and yes, I can see that the files are never created.

    Vincent
  • Hi Vincent,

    I am not able to replicate this issue locally. Can you try to install a new project with the Project Manager, run the project through the built-in web server and try to index?

    Kind regards,
    Ivan Dimitrov
    the Telerik team
  • 254630_Exception.png
    Hi,

    I have the same issue, I created a news index, I am trying to re-index it but I got "Exception has been thrown by the target of an invocation" (as shown in the attached screenshot)

    Also, when I created a testing page with the search control, and I am searching with a word in one of the news items, I got "0 searching results".

    I am using version 4.0.1210.0

    Thanks.
  • Thanks I resolved the issue.