Increase file upload size? - General Discussions - General Discussions - Progress Community
 General Discussions

Increase file upload size?

  • Increase file upload size?
  • I would like to know how to increase the maximum file upload size.  I know how to do it for albums but when going through the File Manager via

    Administration > Files > "Upload"

    it says "Max file size allowed: 200.00 KB"

    Is there anyway to increase this?  I am currently using IIS 7 with community edition.  I have tried the tips on this link:

    www.telerik.com/.../upload-uploading-large-files.html

    but was unsuccessful.  Is there maybe a setting in the CMS to increase it perhaps.

    Kind Regards,

    Josh
  • Hi Josh ,

    The setting cannot be modified. If you want to upload files larger than 200kb you can put them directly using VS.

    You can also check the following article which can give you another set of ideas concerning the file upload control.

    Regards,
    Victor Velev
    the Telerik team

  • So what happens if you dont have VS and you want to upload a flash file or a video, which most sites now have. As an end user I have had to go back to my solution partner to get a file uploaded.. is this a CMS or not??
  • Hello Matt,

    We have introduced a new property in our latest release -  MaxFileSize . You can find it in Settings -> Advanced -> System -> FilesModule -> MaxFileSize and change its value to whatever size you want.  Please note that the value is in bytes and the setting is available in build 1501 ( Sitefinity 4.1 SP2 ).

    Greetings,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • RESULT.. cheers :-)
  • Hi,

    The MaxFileSize property is of type integer. It doesn't allow file sizes greater than 1GB. I need to have this set to max. 2GB. How can I allow Sitefinity to upload files of 2GB max.?

    Kind regards,
    Daniel
  • Hi Atanas,

    Thanks for the follow up. I'll use your solution for now.

    Kind regards,
    Daniel
  • Hello,

    I have checked and you are correct. The issue has been logged for fixing. Currently, you can try setting MaxFileSize to 0 and allow bigger than 1GB files to be uploaded.

    I apologize for the inconvenience.


    Regards,
    Atanas Valchev
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items