Turn off caching for admins? - General Discussions - General Discussions - Progress Community
 General Discussions

Turn off caching for admins?

  • Turn off caching for admins?
  • Is there a way to turn of caching by role? I want to turn it off for admins because it makes editing the site deceptive. Caching sticks even though admins made changes so it does not make sense for them.
  • Hello Basem,

    That's a tough one - we do not offer such functionality. You'll have to either turn it off or choose/setup your own caching profile that responds to your caching requeremetns. If you have any additional questions, please write back.

    Regards,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • Dear Basam

    I have set caching to 5 min sliding. I crated a simple widget with a label and the time to test the caching.

    The time stays, but if I repubish a page the changes are reflected immediately.

    What kind of chaing do you have?

    Markus
  • Thanks Markus and Boyan. It seems when I update the template of a page, the changes are not reflected on the frontend until I explicitly go into the page and re-publish it (or the caching runs out). Then the changes of the template kick in.
  • Have you upgraded your 4.1 to 4.1 SP1

    Because that was one of the fixes in SP1

    Version Notes

    Sitefinity 4 4.1 1395

    Subscribe for the telerik Product Updates RSS feed

      Release Notes – 4.1 SP 1


      • Templates: Updating a template is not reflected on the page until the page is republished (PITS)

       

      Markus

    1. This site is running 4.1, I will try upgrading to SP1 and report if the problem persist. Thanks a mil Markus!
    2. Guys,

      I'm running into a development headache.

      I've used advanced settings to enable all of the "No Cache" settings and disable all of the caching, however, when I try modify a user control via Studio (running Cassini) it seems to cache my UserControl until I stop Cassini and restart it.

      This greatly increases the time it takes for me to debug and build new functionality.

      How can I force Sitefinity to only use the version of my UserControl that I am actively developing upon?

      Thanks!
      Joel

    3. Anybody?
    4. Hello Joel,

      You can try implementing CacheSubstitution for that control, please take a look at this article from ASP.NET, and let us know if the functionality described suits your needs.

      Best wishes,
      Boyan Barnev
      the Telerik team
      Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    5. I had similar concern but when upgraded from 4.1 to 4.1 SP1, the problem was fixed. I hope the upgrade works for you too.
    6. 'would be sweet if there was a cache substitution layout control :)
    7. Just to clarify, for myself:

      The substitution control would correct any issue's I had with markup emitted on a user control.

      What I'm experiencing is the desyncronization of my <usercontrol>.asxc.cs (the code behind) for my user controls. I don't know if it's a function of .net 4 or Sitefinity, but after a control successfully loads, I must stop and restart my web server in order for it to see my changes to user control.

      Workflow to reproduce:

      Create a new user control with a label:
      <%@ Control Language="C#" AutoEventWireup="true" CodeFile="TestControl.ascx.cs" Inherits="OSCPA.Web.UI.TestControl" %>
      <asp:Label ID="lblSomeText" runat="server"></asp:Label>
      using System;
      using System.Collections.Generic;
      using System.Linq;
      using System.Web;
      using System.Web.UI;
      using System.Web.UI.WebControls;
       
      namespace OSCPA.Web.UI
          public partial class TestControl : System.Web.UI.UserControl
          
              protected void Page_Load(object sender, EventArgs e)
              
                  lblSomeText.Text = "Some Text";
              
          

      Add that new control to Sitefnity's Toolbox.config file
      Create an empty page and add the user control to the page
      Publish
      View the page
      Make a change to the code of the control
      using System;
      using System.Collections.Generic;
      using System.Linq;
      using System.Web;
      using System.Web.UI;
      using System.Web.UI.WebControls;
       
      namespace OSCPA.Web.UI
          public partial class TestControl : System.Web.UI.UserControl
          
              protected void Page_Load(object sender, EventArgs e)
              
                  lblSomeText.Text = "Some Different Text";
              
          
      Save your change in studio and refresh the page.

      In Visual studio, my new code behind no longer matches what sitefinity is emitting, so my breakpoints are not hit.

      In order for my breakpoints to be hit, I must stop Cassini (or IIS7) and restart it.
    8. Hello,

      Caching is turned off by default for Administrators, in Sitefinity 4.2.

      Best wishes,
      Georgi
      the Telerik team
      Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    9. Georgi,

      Am I correct in assuming that the <usercontrol>.ascx.cs files are being cached somewhere in Sitefinity (perhaps as widget templates)?

      I haven't dug thru reflector to find anything. I'm only commenting on my external findings, it could very well be a function of Studio 2010; for all I know.

      Thank you!
      Joel