Post cache substitution is not compatible with modules in the IIS integrated pipeline that modify the response buffers. - General Discussions - General Discussions - Progress Community

Post cache substitution is not compatible with modules in the IIS integrated pipeline that modify the response buffers.

 General Discussions

Post cache substitution is not compatible with modules in the IIS integrated pipeline that modify the response buffers.

  • Post cache substitution is not compatible with modules in the IIS integrated pipeline that modify the response buffers.
  • Today I upgraded my Sitefinity project to version 5.0.2860.0 Unfortunately this didn't work as expected. When I login everything seems to work as expected, but as soon I logout I get the exception underneath. I get this exception on every page except the login page. As soon as I login everything works as expected again. What have I done wrong in the upgrade?


    Post cache substitution is not compatible with modules in the IIS integrated pipeline that modify the response buffers.  Either a native module in the pipeline has modified an HTTP_DATA_CHUNK structure associated with a managed post cache substitution callback, or a managed filter has modified the response.
  • Hey El Barto,

    This happens because of a default setting in the web.config in v5.0 (which will be removed in the next versions)
    <urlCompression
     doDynamicCompression="true"
     doStaticCompression="true"
     dynamicCompressionBeforeCache="set this to false instead of true"/>

    Check the dynamicCompressionBeforeCache line in your web.config, it probably is set to true, once set to false everything works again. 

    Jochem
  • That solved it. Thanks Jochem
  • Thanks for this...got me running on arvixe after considerable consternation.
  • Hi,

    This post is quite old, but I am having same problem with newer version of Sitefinity.

    I am having similar problem where it shows this error when I logout from my website. I have another copy of website which has same web.config and I don't see this error. I checked config for dynamicCompressionBeforeCache and it is set to false for both websites (one where I have problem and one where I have not). I compared both web.config files and it does not have any difference. 

    I am running sitefinity 6.3.

    Any help is greatly appreciated.

    Thanks
    Atit