Control Error for Sitefinity Blog - General Discussions - General Discussions - Progress Community
 General Discussions

Control Error for Sitefinity Blog

  • Control Error for Sitefinity Blog
  • Hi,
    I'm not a Sitefinity developer, and I'm working with a site that is using quite an old version of Sitefinity.  I'm working on reinstating an old blog, and when I view the page, it throws the following error: 

    A required control was not found in the template for "~/Sitefinity/ControlTemplates/Blogs/ContentViewItemList.ascx". The control must be assignable form type "System.Web.UI.WebControls.Repeater" and must have ID "repeater".

    [TemplateException: A required control was not found in the template for "~/Sitefinity/ControlTemplates/Blogs/ContentViewItemList.ascx". The control must be assignable form type "System.Web.UI.WebControls.Repeater" and must have ID "repeater".]
    Telerik.Cms.Web.UI.GenericContainer.ThrowException(Type requiredType, String controlId) +58
    Telerik.Cms.Web.UI.GenericContainer.GetControl(String id, Boolean required) +173
    Telerik.Cms.Engine.WebControls.ItemListContainer.get_RepeaterControl() +17
    Telerik.Cms.Engine.WebControls.ContentView.CreateContentList() +1167
    Telerik.Cms.Engine.WebControls.ContentView.CreateChildControls() +4761
    Telerik.Blogs.WebControls.BlogPosts.CreateChildControls() +21
    System.Web.UI.Control.EnsureChildControls() +87
    System.Web.UI.Control.PreRenderRecursiveInternal() +44
    System.Web.UI.Control.PreRenderRecursiveInternal() +171
    System.Web.UI.Control.PreRenderRecursiveInternal() +171
    System.Web.UI.Control.PreRenderRecursiveInternal() +171
    System.Web.UI.Control.PreRenderRecursiveInternal() +171
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +842

    I can see that the ContentViewItemList.ascx is there under the file path that it is supposed to be, as well as the resx file, but I honestly don't know what's missing or what I'm looking for to fix the error so we can view the page. The graphic editor still works properly, but as soon as you switch to the page view, the error prevents the blog from being seen. I have looked at other threads where people have had this problem, but I simply don't know what to do with the code snippet given to fix things. Any help would be greatly appreciated!

    Gina