Adding a custom module give "Could not load type" error - General Discussions - General Discussions - Progress Community
 General Discussions

Adding a custom module give "Could not load type" error

  • Adding a custom module give "Could not load type" error
  • I have a working custom module but I need multiple versions so I copied it and renamed the files according then made changes as needed. I was sure to replace references to the copied file to the new files.

    I updated my Toolboxesconfig.config file accordingly under my currently working module:

     <add enabled="True" type="~/Custom/Forms/CaringTogetherLetterWhaleShark/CaringTogetherLetterWhaleShark.ascx" title="Caring Together Letter - Whale Shark" visibilityMode="None" name="CaringTogetherLetterWhaleShark" />

    I then uploaded my new modules into the same place as my others, updated the Toolboxesconfig.config file and did a reset by doing this: "Administration -> Settings -> User Authentication" and selecting "save changes". I did this according to http://docs.sitefinity.com/administration-application-restart.

    My new modules show up at the expected location in the toolbox but when I try to add them I get the error

     Could not load type 'SitefinityWebApp.Custom.Forms.CaringTogetherLetterWhaleShark.CaringTogetherLetterWhaleShark'.

     I've double check but everything seems to be registered and I've replaced the needed areas in the new files from the copied files.

  • The SitefinityWebApp.dll has been updated?