Image galleries; Lightbox script not working - Front- & Back-End Development - Front- & Back-End Development - Progress Community
 Front- & Back-End Development

Image galleries; Lightbox script not working

  • Image galleries; Lightbox script not working
  • I'm inserting an image gallery control on a page, and trying to use the "Thumbnails + Overlay (lightbox) option. The lightbox script does not appear to parse correctly - I get a bulleted list of thumbnails, and when I click on these, the page refreshes and the full sized image appears at the bottom of the page.

    Am I missing something?
  • Hi John,

    Can you check if the files needed for the fancybox are loaded correctly - a CSS and a JS file. This could happen if you use custom template with custom theme and missed to provide these files in your files structure. Also you can provide us a link to the live (test) site so we can check the things in-place.


    Regards,
    Jordan
    the Telerik team
  • I'll PM you a link. Thanks.
  • Actually, can you just provide an example of the link to the fancybox script?
  • 258235_fancybox-min.zip
    Hello John,

    The fancybox script is attached.

    Greetings,
    Jordan
    the Telerik team
  • Place this in the 'scripts' folder?
  • Hello John,

    Please check what is the path where the site is looking for the script. You can use Firebug and see in the Net tab where should be the missing files.

    Best wishes,
    Jordan
    the Telerik team
  • I'm having this problem too.....

    Except Firebug is telling me that the script is being loaded (searching scripts for "fancybox" yields one that starts with
    "/* START Telerik.Sitefinity.Resources.Scripts.jquery.fancybox-1.3.1.js */")

    Jules
  • Hello Julia,

    Thank you for sharing the script loading information. This is how the script should be loading. I suppose the appearance of images as bulleted items is caused by no styles loading for the image gallery. Can you examine with firebug if css is applied to the gallery. Maybe you are using a theme or css in a css widget on the page(or at the master page) that is conflicting with the css of image gallery. If you have no such css conflicts can you take the css output of a image gallery(from a project where the gallery is working) and paste it in a css widget on the page with the gallery. This should solve the problem.

    Regards,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • 297285_lightbox-screenshot.png
    Sorry it's taken me so long to get back to this. It looks like there's no CSS being applied at all to the lightbox-related CSS classes. (See attached screenshot.)
  • Hello Julia,

    Thank you for providing the screenshot. This is an issue when you upgrade your project to Sitefinity  4.1.
    To fix it add the missing css to a css widget on the same page or in the theme that the page is using. The problem is resolved in upper versions.
    .sfimagesTmbList .sfimagesTmb
        display: inline-block;
        height: 120px;
        overflow: hidden;
        padding: 10px;
        width: 120px;
    .sfimagesTmbList a
        display: block;
        height: 120px;
        overflow: hidden;
        text-align: center;
        width: 120px;
    .sfimagesTmbList img
        vertical-align: middle;


    Best wishes,
    Stanislav Velikov
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

  • Ok. That worked. But when you say "resolved in the upper versions," what do you mean? I'm running SF 4.2.....
  • Hi Julia,

    I am happy to hear you resolved it. I have seen this error when a project was upgraded to Sitefinity 4.1, but not to Sitefinity 4.2. Excuse me for this I was unaware this was still an issue.

    Best wishes,
    Stanislav Velikov
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

  • I also have the same issue.
    The provides CSS works only for newer browsers. When running IE8 in compatability mode, the bullets will still show.