Silverlight Widget Beta 2 Not Showing - Front- & Back-End Development - Front- & Back-End Development - Progress Community
 Front- & Back-End Development

Silverlight Widget Beta 2 Not Showing

  • Silverlight Widget Beta 2 Not Showing
  • 223489_comicwidget.png
    Hey support guys,
    I am walking through the new Advanced Silverlight Widget sample in the Beta 2 SDK and I can't get it to show up in my toolbox to be able to add it to a page. What am I missing?

    Attached is a screen shot of my Settings in Sitefinity and below is the code.

    Widget Code
    using Telerik.Sitefinity.Web.UI;
    using System;
    using System.Collections.Generic;
      
    namespace ComicWidget
        public class Comic : SimpleScriptView
        
            public override  IEnumerable<System.Web.UI.ScriptDescriptor> GetScriptDescriptors()
            
                throw new NotImplementedException();
            
      
            public override IEnumerable<System.Web.UI.ScriptReference> GetScriptReferences()
            
                throw new NotImplementedException();
            
      
            protected override void InitializeControls(GenericContainer container)
            
                  
            
      
            protected override string LayoutTemplateName
            
                get return "ComicWidget.Resources.Views.ComicTemplate.ascx";
            
        


  • Hi Garry Clark,

    If you have successfully completed the step "Register the widget in Sitefinity" part of our "How to create an advanced Silverlight widget" then you have to make sure that the appropriate configuration is applied. Would you check with your ToolboxesConfig.config located at App_Data\Sitefinity\Configuration\ whether the following record exists?

    <add name="YourSection" title="YourSectionTitle">
        <tools>
            <add type="ComicWidget.Comic" name="Comic" title="Comic" />
        </tools>
    </add>

    You have to also make sure you have references to the class library in which you are building your widget.

    Thank you for contacting us. Looking forward to resolving your issue.

    Kind regards,
    Hristo Borisov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  • Hristo,
    I checked my config file and I do have this entry in it.

    <add name="Custom">
                        <tools>
                            <add type="ComicWidget.Comic" name="Comics" title="Comics" />
                        </tools>
                    </add>

    Any other suggestions?
  • Hello Garry Clark,

    Then you have to just restart the application by modifying the web.config with a dummy change. Once you run the application the configuration will be applied and your widget must be part of the toolbox.

    Let me know asap if this doesn't resolve your problem.

    All the best,
    Hristo Borisov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  • 224228_widgets.png
    Hristo,
    I have made a change to my web.config file and I even went back and copied your tool config and replaced mine, but as you can see from the screen shot I have no new tools. It now looks like this.

    <add name="Custom" title="Custom Tools">
              <tools>
                <add type="ComicWidget.Comic" name="Comic" title="Comic" />
              </tools>
            </add>

    Any other ideas?
  • Hello Garry Clark,

    It seems that the custom tools section is not created properly. Can you make sure that you have built your client library project and the dll exists in the bin folder of your website? Also can you make sure that adding some other control such as RadMenu (Telerik.Web.UI.RadMenu) to the toolbox will produce the same result.

    All the best,
    Radoslav Georgiev
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.