References are disappeared permanently - Front- & Back-End Development - Front- & Back-End Development - Progress Community
 Front- & Back-End Development

References are disappeared permanently

  • References are disappeared permanently
  • when editing sitefinity project in VS .Net 2010 References are disappeared permanently,
    also message of can not load Telerik.Web.Design.dll is appeared and many other dlls also.
    what i do right now i copy the missed or not loaded dlls from another project.
    Please clarify  that to me.
  • although I do not have an explanation as to why this happens, I know that one of the causes is if you use a "Rebuild" instead of a "Build" in visual studio. I use "Build" exclusively and never receive this issue.
  • After rebuild stile some references not loaded
    like
    1-  'Microsoft.IdentityModel
    2-
    Telerik.Web.UI
    3 -
    Telerik.Sitefinity.Analytics .*
    4-
    Telerik.Sitefinity.Utilities
    5- Microsoft.Practices.ServiceLocation
    .....   and more
    can sitefinity people reply to me please

  • Hello Hosam,

    The project references will disappear if you hit rebuild for the project. Rebuild does a complete recompile of whatever you select and you will most likely get the error: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

    However, the build action is incrеmentаl. It will rеcompilе thе bits thаt hаvе chаngеd, and in a multi-project solution will rеbuild оnly projects affectеd by the mоst recent change.

    Therefore you will have to add all needed references to your project  again and the errors will disappear.

    Greetings,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • Victor,

    I have added all resources back into the project and yet still the server still just tells me that the server is restarting.
  • Hi Ian,

    Can you elaborate a bit more on your particular situation regarding the message? When did you start to see it? Have you removed all references, cleaned and then added them all back to build the solution?

    Kind regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items