Redirect to HTTPS after upgrade to SF8.0 - Front- & Back-End Development - Front- & Back-End Development - Progress Community
 Front- & Back-End Development

Redirect to HTTPS after upgrade to SF8.0

  • Redirect to HTTPS after upgrade to SF8.0
  • 8cf8501e-37c1-6deb-a958-ff0000446526_httpredirect.png

    Hi All,

    I'm Using SF 7.0  and Upgrade solution to SF8.0 using with Sitefinity Project Manager

    But After upgrade I'm trying to access dashboard its Redirecting to(localhost/.../SWT)and showing 404 Page not found (please find attached image for reference) .

    we did not add any rule in web.config for redirecting HTTPS, but its Redirecting HTTPS

     i removed all rewrite Rules in web.config and added

    <wsFederation passiveRedirectEnabled="true" issuer="http://localhost" realm="http://localhost" requireHttps="false" />

    And storing config files in Database

    <telerik>
      <sitefinity>
        <!--<environment platform="WindowsAzure"/>-->
        <sitefinityConfig storageMode="Database" />
      </sitefinity>
    </telerik>

     

    Please help me, How to solve this issue? why its redirecting https instead of http?

     

    Thanks & Regards,

    Ajay

     

  • Hello,

    Could you check in your App_Data\Sitefinity\Configuration\SecurityConfig.config that the realm is using an HTTP URL and not an HTTPS?

    Regards,
    Sitefinity Laurent
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  • Hi Team,

    We are facing similar issue after upgrading to 8.0 from 7.0.  We have enabled the database storage mode for the configuration and facing the redirection to https issue upon navigating to the backend.

    SecurityConfig in App_data folder:

    <securityTokenIssuers>
    <add key="1F6B5FFA3A88166309CD567633629C6FDF12E9B25CAB78DEE379C4892E6C715E" encoding="Hexadecimal" membershipProvider="Default" realm="http://localhost" />
    </securityTokenIssuers>
    <relyingParties>
    <add key="1F6B5FFA3A88166309CD567633629C6FDF12E9B25CAB78DEE379C4892E6C715E" encoding="Hexadecimal" realm="http://localhost" />
    </relyingParties>

    SecuritConfig in Database:

    <securityConfig />

     

    Please help us resolve this issue.

     

    Thanks,

    Ravikanth​

  • Hello,

    Could you check both your web.config and SecurityConfig.config files and make sure there is no "https" URL or "requireHttps" flag set to true?

    Regards,
    Laurent Poulain
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items