No row for Telerik.Sitefinity.Pages.Model.PageData - Bugs & Issues - Bugs & Issues - Progress Community

No row for Telerik.Sitefinity.Pages.Model.PageData

 Bugs & Issues

No row for Telerik.Sitefinity.Pages.Model.PageData

  • No row for Telerik.Sitefinity.Pages.Model.PageData
  • I'm getting the following error

    No row for Telerik.Sitefinity.Pages.Model.PageData ('sf_page_data') GenericOID@83fe0719 PageData content_id=9d594dd9-83a7-4a2f-b338-9d333ea95fee NOTRES

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: Telerik.OpenAccess.Exceptions.NoSuchObjectException: No row for Telerik.Sitefinity.Pages.Model.PageData ('sf_page_data') GenericOID@83fe0719 PageData content_id=9d594dd9-83a7-4a2f-b338-9d333ea95fee NOTRES

    Source Error:

    Line 11:             if (currentNode != null) 
    Line 12:                 var pManager = Telerik.Sitefinity.Modules.Pages.PageManager.GetManager();
    Line 13:                 Telerik.Sitefinity.Pages.Model.PageData page = pManager.GetPageData(new Guid(currentNode.Key));
    Line 14:                 return page;
    Line 15:             

    Source File: C:\Code\SF4_RC\App_Code\PageHelper.cs    Line: 13

    Stack Trace:

    [NoSuchObjectException: No row for Telerik.Sitefinity.Pages.Model.PageData ('sf_page_data') GenericOID@83fe0719 PageData content_id=9d594dd9-83a7-4a2f-b338-9d333ea95fee NOTRES ]
       DynamicModule.ns.Wrapped_OpenAccessPageProvider_cc1b7352ad604752885546fdb55a9865.GetPageData(Guid id) +481
       Telerik.Sitefinity.Modules.Pages.PageManager.GetPageData(Guid id) +113
       PageHelper.get_CurrentPage() in C:\Code\SF4_RC\App_Code\PageHelper.cs:13
       SitefinityWebApp.Custom.Menu.Page_Load(Object sender, EventArgs e) in C:\Code\SF4_RC\Custom\Menu\Menu.ascx.cs:28
       System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +25
       System.Web.UI.Control.LoadRecursive() +71
       System.Web.UI.Control.LoadRecursive() +190
       System.Web.UI.Control.LoadRecursive() +190
       System.Web.UI.Control.LoadRecursive() +190
       System.Web.UI.Control.LoadRecursive() +190
       System.Web.UI.Control.LoadRecursive() +190
       System.Web.UI.Control.LoadRecursive() +190
       System.Web.UI.Control.LoadRecursive() +190
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3048
    


    Here's the offending Code


    public static Telerik.Sitefinity.Pages.Model.PageData CurrentPage
            get
                SiteMapNode currentNode = SiteMap.CurrentNode;
                if (currentNode != null)
                    var pManager = Telerik.Sitefinity.Modules.Pages.PageManager.GetManager();
                    Telerik.Sitefinity.Pages.Model.PageData page = pManager.GetPageData(new Guid(currentNode.Key));
                    return page;
                
                return null;
            
        


    I just wanted to display some info on the current page inside a widget...

  • Hi Steve,

    Please modify your code as shown below.

    SiteMapNode currentNode = SiteMap.CurrentNode;
    if (currentNode != null)
        var pageNode = currentNode as PageSiteNode;
         
        Telerik.Sitefinity.Pages.Model.PageData page = pManager.GetPageData(pageNode.PageId);
     


    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • We're experiencing the same issue except that we aren't doing any custom coding and the error message is displayed in an alert window when we try to load the page templates:

    No row for Telerik.Sitefinity.Pages.Model.PageData ('sf_page_data') GenericOID@a60524bb
    PageData Content_id=0c346ef6-1231-4a3b-8196-b8e79ee0ac76

    We're pretty much dead in the water since the alert box perpetually pops up after every attempt to close it. The only way to get access to the browser is to kill the process tree from Windows Task Manager and restart the browser.
  • Hi Chris,

    We received several other reports with the same issue and it is possible that this is a bug in Sitefinity. We will need some more time to investigate this issue and update all requests. If you have some other information that would help us to narrow down the issue, please let us know.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • I have no idea if this will fix your problem, but it appears to have fixed mine...

    All was good on Sitefinity until I dropped a search module onto a page and didnt configure it (because I had not yet created a search index).  Although I was able to publish this page, every page I attempted to publish afterward threw the "No row" error.  So I went into Administration > Search & Indexing and created a search index.  As soon as the index was in place, I was able to publish pages again.

    I hope this helps!

  • I learned that by recycling the the application pool in IIS, the error went away, and I haven't seen it since, so I guess I'm good for now.
  • Deleting and recreating the search index worked for me, as well.
  • Hi David,

    You can also try disabling the second level cache from the configuration settings.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • I managed to get this error after mucking about in the sandbox for about an hour. Above solutions would not work for me so I duplicated an existing page, went to change that pages template, grabbed an existing template and made that the default. Now everytning is working again.

    The error, at least in my case seemed to be the result of a corrupt default template. FWIW, I had not modified any templates but I did apply a different template to an existing published page just prior to the error first appearing.

    I know this is rambling, but hope it can help some else.
    Bob
  • Is this a confirmed work around, or is it something that is just working for some people?
  • Hello,

    Disabling second level cache should work for all cases.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • Ivans code modification 27 DEC 2010LINK TO THIS POST, was the resolution for me. I'd rather make a code change then change other functionality and scope of the change. Hope this helps someone. This occurred in 6.3.5000. 
  • I have been experiencing this error as of late quite a bit trying to make edits to a page.  We recently upgraded from 5.4 to 8.1.  I believe the issue is related to caching, but unsure on how to fix the issue.  It was mentioned to disable second level cache from configuration settings.  How/where is this done?
  • Jared. It's somewhere in advanced settings I believe. I'll check when I get to the office