Lightbox image being loaded into same page - Bugs & Issues - Bugs & Issues - Progress Community
 Bugs & Issues

Lightbox image being loaded into same page

  • Lightbox image being loaded into same page
  • Hi

    I'm using the lightbox option in the image gallery and the image is loading in underneath my current site layout on the same page... any ideas why this is happening?

    Thanks...

    Cheers
    Richard
  • Hello Richard,

    This looks like as an issue with the z-index or you are applying some css classes that overay the div used by LightBox.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • Hi Ivan

    I've used the css from the sdk hospital theme, just to get the css elements identified:

    .sfLightboxMode li.sfimagesTmb

        position: relative;
        float: left;
        margin: 5px;
        border-right: 1px solid #bbb;
        border-bottom: 1px solid #bbb;
        list-style: none;
        list-style-type: none;

    .sfLightboxMode li.sfimagesTmb a

        display: block;
        position: relative;
        float: left;
        border: 5px solid #efefef;
        width: 76px;
        height: 76px;
        overflow: hidden;

    .sfLightboxMode li.sfimagesTmb a:hover border: 5px solid #d5d5d5;
    .sfLightboxMode li.sfimagesTmb a img padding: 0;

    Anything there look dodgy?

    Thanks...

    Cheers
    Richard

  • Hi Richard,

    Is there a demo/live page that we can see what is going wrong with the LigthBox.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • Here we are:

    http://cms.fulcrum.smarterworks.co.uk/clients/case-studies/the-papal-visit-cofton-park

    Thanks

    Cheers
    Richard
  • Hi Richard,

    I am getting 404 error when I try to access the link. Can you update it please?

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • Hi Ivan

    Should be ok now... you managed to pick the 5mins where I stopped IIS7 to copy the site across! :-)

    Thanks

    Cheers
    Richard
  • Hi

    Please can this be looked at asap. I think my master page might be missing the javascript reference. I have copied the instructions for creating a template from a master page that yiou have published. Can you check that this is correct and will bring in the scripts... the script bit under the form tag doesn't have a closing tag, is this right, can you check through and let me know... that page is stil up there for you to look at.

    Thanks

    Cheers
    Richard
  • Hi

    More checking and it works ok in the site when using one of your templates, but when using the template I created based on a master page it doesn't, what am I missing from the master page that means it doesn't work?

    Thanks

    Cheers
    Richard
  • 247684_fancyboxcss.gif
    Hi Richard Cross,

    The path to the CSS file of the lightbox (fancybox) is incorrect. Now it is pointing to

    cms.fulcrum.smarterworks.co.uk/.../fancybox.css

    and it should be

    cms.fulcrum.smarterworks.co.uk/.../fancybox.css

    So, move the file in the "Styles" folder or change the path to the "css" folder.

    Greetings,
    Jordan
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • Hi Jordan

    I haven't done anything with linking style sheets, I'm only using the main.css in the Global folder, this must all be automatically done by Sitefinity. Sitefinity is obviously providing the current link to the wrong folder, how do I tell it to go somewhere different? Sitefinity has put the style sheet in that folder and given the wrong link. Obviously this is something that will have to be changed for a future release. I can't alter the path as this is generated automatically so I will have to move the file, will this follow through what you will do in a future release?

    Thanks

    Cheers
    Richard
  • Update.... I don't have a Styles folder, how can I get Sitefinity to look in the CSS folder as you say?
  • Hello Richard Cross,

    On you server there is a file

    http://cms.fulcrum.smarterworks.co.uk/Sitefinity/WebsiteTemplates/TEMPLATE001/App_Themes/THEME001/css/fancybox.css

    You just need to create a folder called Styles in .../App_themes/THEME001/ and move this file in it.
    --------------------------------------------------------------------------------------------------------

    The CSS of the fancybox is included by default with the default theme. If you want to use the built-in fancybox functionality with your custom theme you need this file in the Styles folder.


    Kind regards,
    Jordan
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • Thanks Jordan

    Understood... the three folders detailed in your custom theme instructions are, Global, CSS and Images. Is this incorrect then? Should CSS be Styles? Will it change to this for future releases or is this an additional folder that custom themes require?

    Thanks

    Cheers
    Richard