Server Error 404 - File or directory not found. - Bugs & Issues - Bugs & Issues - Progress Community

Server Error 404 - File or directory not found.

 Bugs & Issues

Server Error 404 - File or directory not found.

  • Server Error 404 - File or directory not found.
  • Hi,

    the face of a very mysterious problem. On the live server I uploaded the "empty project",installation was trouble-free, I entered everything needed to connect to the database.After logging in, seamlessly screen "Dashboard".

    The problem occurs when I try to choose an option. I wanted to convert the basicsettings of the project, but Sitefinity I get an error message "Server Error 404 - File or directory not found.". Once I checked that the server some files are missing, everything was fine.

    I changed the authorization in web.config, I forbade "Basic Authorization", did not help.

    So I tried again to upload the whole project again, installation went without problemsagain, but the problem was repeated.

    He met with by someone?

    Am I doing something wrong?

    I use version 4.0.1098.0 - Community

    I will be grateful for any idea.
  • Hi Patrik,

    Can you please make sure that you have all the required windows features installed and running. For reference, please check this article. Most probably you have not enabled WCF.

    Best wishes,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • On my local server Sitefinity works well, the problem occurs when I put the project onweb hosting.

    All necessary functions supported hosting.
  • I updated web.config, I added the handlers *.svc and *.xamlx, chech the support WCF in my hosting, Sitefinity but I still have an error 404 File or directory not Foud.

    What's wrong?

    Handlers have mapped as follows:

    <httpHandlers>
          .
          .
          .
          <add verb="*" path="*.xamlx" type="System.Xaml.Hosting.XamlHttpHandlerFactory, System.Xaml.Hosting, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>
          <add verb="*" path="*.svc" type="System.ServiceModel.Activation.HttpHandler, System.ServiceModel.Activation, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>
        </httpHandlers>

  • I have this exact issue with 4.0 standard as well, here are the entries in my web.config...

    <!-- CUSTOM -->
            <add name="svc-ISAPI-4.0_64bit" path="*.svc" verb="*" modules="IsapiModule" scriptProcessor="c:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll" resourceType="Unspecified" preCondition="integratedMode" />
            <add name="xamlx-ISAPI-4.0_64bit" path="*.xamlx" verb="*" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll" resourceType="Unspecified" preCondition="integratedMode" />
            <add name="svc-Integrated-4.0" verb="*" path="*.svc" type="System.ServiceModel.Activation.HttpHandler, System.ServiceModel.Activation, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
            <add name="xamlx-Integrated-4.0" verb="*" path="*.xamlx" type="System.Xaml.Hosting.XamlHttpHandlerFactory, System.Xaml.Hosting, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" preCondition="integratedMode" />
          <!-- END CUSTOM -->
  • One more clarification, after the update (as amended) the "web.config" file, it loads the "Advanced Settings", if I want to save the settings Sitefinity reporting a Error 404, the same thing happens when you try to create a new template,  upload the server file "template.master", upload takes place ok.

    When I go on, eg. save and return to a page with templates, action ends with Error 404 File or Directory not Found.

    By mistake my end all attempts at any change in the Sitefinity CMS improsed on Web hosting. On the local PC everithing works without any problems.

    I'm already desperate and the customer is furious as a bull (Im waiting, when ity comes to office :-) ).

    The only thing that calms me how tal are songs from Metallica :).



    Please, please and please help.
  • I'm in the same boat my friend, site is totally useless on an editing front

    The ONLY thing I can suggest to you so they can at least move forward with editing, is to host it off your machine for now pointing to the webhosts DB...that seems to work for me, but it's slow....
  • I got the same issue and found the solution finally by tracing the root of this issue.

    Problem's Root:
    This problem occurs because no verbs are added to the <verbs> section in the applicationHost.config file. Additionally, the allowUnlisted property of the <verbs> section is set to false. This setting denies all the requests that add verbs that are listed in the <handlers> section. The <handlers> section is under the <system.webServer> node in the applicationHost.config file.

    Following are the steps to resolve this issue:

    1. In a text editor, open the ApplicationHost.config file.
    2. The ApplicationHost.config file is in the following folder:
         %SystemRoot%\system32\inetsrv\config (usually on c:\windows\system32\inetsrv\config)
    3. Locate the <verbs allowUnlisted="false" /> tag.
    4. Change this tag to <verbs allowUnlisted="true" />.

    Cheers!

    If you do not want to allow all the unlisted verbs for security reasons, you can explicitly add these verbs. For example, you can replace the <verbs allowUnlisted="false" /> tag with the following code:
    <verbs  allowUnlisted="false">
        <add verb="GET" allowed="true" />
    </verbs>
  • Sadly...that did not seem to fix me up :/
  • They do not really know what to do, so I managed to run a functional website build on Sitefinity.

    The original files ApplicationHost.config value is determined as follows:

    < slovesa allowUnlisted = "true" applyToWebDAV = "true" />

    Does anyone have any idea what could cause a malfuction?

    Thanks.
  • I'm at a loss too...I have a ticket in, no followup yet on it

    This host will literally make any change I want, but I just have no idea what to tell them to do
  • It seems that you got this issue in different situation. I got this issue in Windows Server 2008 Standard, when I tried to do any operation through CMS backend (i.e. Image Upload, add content editor in page etc).

    Check the web server logs to find out helpful description for this issue related. Try to replicate the issue on Server's browser instead of remote location; you might get some more information there.

    Unfortunately, the alert message "Server Error 404 - File or directory not found." is not descriptive. I was getting this message only when I accessed the CMS from Internet; but when I accessed it locally on Web Server, it showed me the "404.6 HTTP - verb denied" error and that helped me a lot to find the actual issue.

    Regards.
  • The error message "Server Error 404 - File or directory not found" popping up in the back end of Sitefinity might be due to the website being run in a Medium Trust environment. Changing the environment to Full Trust should resolve the issue.
  • Hi Guys,
    I had the same issue and it turned out to be a configuration issue in URLscan. In the URLscan logs I had the following:

    Client at xxx.xxx.xxx.xxx: URL contains '.' in the path. Request will be rejected.  Site Instance='1673214664', Raw URL='/Sitefinity/Services/Security/Users.svc/'

    After reconfiguring URLscan correctly everything worked.

    Hope this helps
    thanks
    Richard