Image Manager broken? - Bugs & Issues - Bugs & Issues - Progress Community
 Bugs & Issues

Image Manager broken?

  • Image Manager broken?
  • 248535_Imagetool.PNG
    When I'm working in the WYSIWYG editor (such as in a content block) and look at the properties for image I've dropped in, if I click on the little landscape symbol to choose a different image I get the mess I've attached shown to me. Is anyone else seeing this?

    This is IE8 on Windows 7.
  • Hello Zak,

    The Image Manage of the RadControls>Editor is not broken. This is the default image dialog for RadControls>Editor. This editor is different than Sitefinity's Content Editor and the insert image dialogs for  these controls are also different.

    Regards,
    Sonya
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • I have the same issue. Are you saying it's behaving as expected? If so, why in the world can we even right click an image and choose properties? Is there some other way to edit the properties of an inserted image?
  • It certainly doesn't appear to be working--I can't figure out how to do anything with it. Scrolling between Page 1 of 2 and Page 2 of 2 doesn't cause anything to happen that I've seen.
  • Hello Zak,

    Please check if the following code is added to your web.config. If the code is missing please add the code below under <httpHandlers> section:

    <httpHandlers>
    <add verb="*" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI, Culture=neutral, PublicKeyToken=121fae78165ba3d4" />

    To set Image Manager:
    • Go to Administration>Files – create new folder named Files and upload few images
    • Go back to the page where RadEditor is and click ‘Edit’
    • Under Image Manager section – define UploadPath /ViewPath  i.e. ~/Files
    • Save
    • Click Image Manager – the images uploaded in ~/Files directory should be listed
    I noticed some issues when you have nested pages and we will need some more time to investigate the issue.

    Another option is creating a custom or user control where you have RadEditor control declared and you should set DialogHandlerUrl="~/Telerik.Web.UI.DialogHandler.axd"



    Greetings,
    Sonya
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • This was always the problem with 3.x as well...there was never a single source for images\documents.  Depending on the control you used (image control or RadEditor) and where you were, you only had access to files in that repository (filesystem or database library)

    Sonya, it gets really annoying really quickly for content editors who have no idea that's the case...it would be awesome if you guys worked towards a single source\single dialog.  So whenever I use an image regardless of where\how I add it, I get the same dialog.
  • Sonya,

    I have a very similar line:

    <add verb="*" validate="false" path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI"/>

    Do I need the one you provided as well?

    Thanks!
  • Hello Zak,

    This is fine. Have you created Files directory in the root of your web application?
    Steve, we are going to sort this out for the service pack.

    Best wishes,
    Georgi
    the Telerik team
  • I have not--is this a requirement, as I don't recall seeing it in the installation documentation?
  • Hi Zak,

    No, it's not in the system requirements - we found that this fixes the issue after the release. Service Pack 1 will contain this directory though, out of the box.
    You may create it, and check if the problem persists.

    Regards,
    Georgi
    the Telerik team
  • Hi Georgi,

    I'm still seeing the issue after creating the Files directory. Does it need any special permissions?

    Thanks!
  • Hello Zak,

    Thank you for getting back to us.

    The FileManager requires permissions to create files in under the Files folder if you wish to upload images from the manager. If you wish only to use the manager for including file links in content blocks you do not need special permissions.

    Best wishes,
    Radoslav Georgiev
    the Telerik team
  • Hi Sonya,

    This Forum is very helpful. Thanks a lot for sharing these great tips.
    I just upgraded from DNN 5.6.3 to DNN 6.0.1 with DotNetNuke.RadEditor provider

    My current Problem:
    I am not able to add / insert images / media files in the HTML editor.
    When I click on "Insert Media" button, "Image Manager" window pops-up. But I don't see any files there.
    Naturally, this is a problem with "Image Path" setting for the Editor in this Child Portal.
    I want to know how to set the "Path" for the images. I can't navigate to any folder - not even portal root folder (I am the host; working on a Child portal)

    Some Observations:
    I opened an existing HTML module with an image in the new editor.
    I right-clicked on the existing image and saw the "Properties"
    I can clearly see the correct path in the "Image properties window".
    Image Src shows the correct Path : /P2/portals/26/logo.gif

    But when I click the "image" icon next to the file name text box, it opens "Image manager" but no list of files (everything is empty; it doesn't even show the file whose properties I was just viewing).

    When I changed the file name directly on the Image Properties window, it picked up the right / correct image and displayed.

    If I don't have an existing image, I can't get to the "Properties" window and do this "work-around".

    Please help me with this: How to set the Image files Path for the new Telerik Editor.

    Thanks a lot in advance!

    ================ Your Guidance ================================
    To set Image Manager:
    • Go to Administration>Files – create new folder named Files and upload few images
    • Go back to the page where RadEditor is and click ‘Edit’ <<< "I can't see any "Edit" button???
    • Under Image Manager section – define UploadPath /ViewPath  i.e. ~/Files
    • Save
    • Click Image Manager – the images uploaded in ~/Files directory should be listed
    ==================================================================
  • Hello Vijay,

    Please, note that version 5.4 or later of DNN uses the Professional provider of RadEditor, which is implementation of the DNN developers and it is not supported by Telerik.

    Our suggestion is to post your question in the DNN forums and contact the support of DNN for help. This article could be also helpful : Taming (customizing) The new Telerik RadEditor.

    You can find information about:



    All the best,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now