Site stopped working randomly - hexadecimal value 0x00, is an invalid character - Bugs & Issues - Bugs & Issues - Progress Community

Site stopped working randomly - hexadecimal value 0x00, is an invalid character

 Bugs & Issues

Site stopped working randomly - hexadecimal value 0x00, is an invalid character

  • Site stopped working randomly - hexadecimal value 0x00, is an invalid character
  • 266641_screenshot.jpg
    I opened a support ticket for this but am posting here as well in case anyone in the community has come across this issue.  I have a Sitefinity 4.1 site.... everything was working fine until last night when the entire site (front end and backend) stopped working.  Everything is just showing the attached error message.

    I haven't made any server changes or even uploaded any files while should've caused this.  It just all of a sudden started happening.  Anyone have any ideas?  I'm not even sure where to begin here.
  • Jay, can you verify that all of your .config files still exist in the App_Data/Sitefinity folder? Looks like a config file is either missing or empty.
  • I have 26 configuration files in that folder.  All appear to be normal as far as I know.  Most have last modified dates of last week and none appear to be empty.
  • Not sure what else to say.  The stack trace is saying there is either an empty file, extra white space or corruption at the very beginning of one of the config files, and digging into the code points to the PagesConfig.config file being bad.
  • 266705_screenshot2-backend.jpg
    Thanks Michael.  I appreciate you trying to help.

    The first screenshot I posted was of the main website homepage.  If I go to the Sitefinity backend I get the same error but with a different stack trace which looks like the Sitefinity Page Manager is crashing.  (screenshot attached)

    I'm wondering if there might be a corrupt value in the database somewhere that's throwing things off... but honestly I'm not even sure where to start looking for something like that.

  • Same underlying cause for both...trying to read in a bad XML file.

    Can you post your PagesConfig.config file?  Should only be two lines.
  • Sure... it'll only let me upload image files here... but the contents are as follows:

    <?xml version="1.0" encoding="utf-8"?>
    <projectConfig projectName="" dateCreated="2011-03-03 02:50:16Z" />

    I even tried overwriting the copy on the server with one I had saved locally and it didn't do anything. 
  • I just checked the Sitefinity log files (should've done that first.. ugh) and it definitely IS that file that's causing the problem.

    04/27/2011 13:05:21
    Type : System.Xml.XmlException, System.Xml, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089
    Message : '.', hexadecimal value 0x00, is an invalid character. Line 1, position 1.
    Source : System.Xml
    Help link :
    LineNumber : 1
    LinePosition : 1
    SourceUri : file:///C:/Inetpub/vhosts/
    Data : System.Collections.ListDictionaryInternal
    TargetSite : Void Throw(System.Exception)
    Stack Trace :    at System.Xml.XmlTextReaderImpl.Throw(Exception e)

    The file looks fine to me though... are there perhaps any permissions that need to be set on that file / folder?
  • File needs to be read-write.

    That said, it looks like you posted your ProjectConfig.config file and not your PagesConfig.config file.

    Can you post the correct file?
  • Apologies... I completely misread that before. 

    You are correct... my PagesConfig.config file has someone been converted to a string of blank characters... which is indeed the root cause of the problem.

    Unfortunately I'm not sure I have a backup of this file.  It looks like it's not part of the install, but something that Sitefinity generates on the fly?  Do you happen to know if there's a default version somewhere that I could use to get things back up and running?
  • Here's mine:
    <?xml version="1.0" encoding="utf-8"?>
    <pagesConfig homePageId="dedf2048-1684-461a-967f-be1d7d174f20" xmlns:config="urn:telerik:sitefinity:configuration"  config:version="4.1.1339.0" />

    After replacing yours with mine, you'll have to go back into the backend and reset your home page.

    If you still have a problem, just try deleting the file and let it regenerate.
  • I actually did find a backup right after I posted that last message and that completely fixed the problem!

    I can't thank you enough for your help on this Michael.  You are a lifesaver. 
  • Huge thanks Michael!  Jay, I'm delighted everything is now back online

    Gabe Sumner
    Telerik | Sitefinity CMS