SSL creates redirect loop - Bugs & Issues - Bugs & Issues - Progress Community
 Bugs & Issues

SSL creates redirect loop

  • SSL creates redirect loop
  • Hi all,
    Just looking to see if anyone else has encountered this issue. (I did put in a support request also). I created a page and set Require SSL to true. However, this creates a redirect loop and the page will not open.

    This does not occur when I access the page internally from within the network where the site is hosted. However, any external attempts result in the redirect.  I"m assuming it has something to do with server or firewall settings, but I don't know enough about how Sitefinity forces the SSL redirect to know.

    Any ideas on fixes would be greatly appreciated. Thanks!
  • I am having the exact same problem. The server or firewall sending the site to https:// and the SF page redirecting back to http://
  • Hi
    We've found that it is something in Microsoft ISA. We still haven't found what exactly it is causing the issue.
    We set up a completely seperate ip with a different firewall and the site worked fine. We might get to more troubleshooting later this week and I'd be happy to let you know what we discover.

  • Came across the same issue -- Can you let me know if you managed to resolve this somehow/someway?
  • I know this isn't any help, but we never did find out the issue. We ended up taking it out of our normal company firewall and setting it up on its own line with a physical firewall of its own.
  • Does the actual page have "RequireSSL" set to true in it's properties? Otherwise it will always redirect to the non-secured page location when you try and hit it. I agree, it's kind of a bad design, but you improved SSL handling is on the roadmap supposedly for a future version.

    Note, there are posts around with code examples of how to loop through and set every page to RequireSSL = true, and if you want that to be the default you can compile a custom PageService for pages and set the page service to use yours and always set RequireSSL to true on making a new page.