Google Analytics problem - Bugs & Issues - Bugs & Issues - Progress Community
 Bugs & Issues

Google Analytics problem

  • Google Analytics problem
  • 391899_For-Google-Analytic.png
    I have added My GA code in <head> tag of my Template and then i m click on Analytic from Sitefinity Backend.
    I have login with my login credentail for Google Analytic, it is succesful but after that it gives me the error message as
    "Analytic User Permission Configuration File is Corrupt".
    please see the attached image for  this issue.

    Thanks in advance
  • Dear Jignesh

  • Hi Markus,

    I'm not so sure it did fix it completely. I just upgraded to 5.1 SP2 in
    order to use the GA integration and and am seeing the same behavior as Jignesh.
    I checked the Telerik.Sitefinity.Analytics.Server.GoogleAnalyticsPlugin.dll and it
    really is 5.1.3450.0. I suspect there's still a problem.

    Cheers,
    Geoff

  • I've just upgraded to SP2 as well and still get the message saying my config file is corrupt. I've even deleted the config file from the site so that it makes a new one for me, but still get the error.

  • Hello,

     Would it be possible to try the following: Go to App_Data/Sitefinity/Configurations and delete AnalyticsConfiguration and DashboardPermissions files (and .bak if there are any) then try configuring Analytics again. If you do not get any Sitefinity users to choose from, run the code from this KB:No administrator users are listed when configuring Sitefintiy Analytics and then configure Analytics again. After that everything should be working fine. I was just testing it and it is working Ok.

    Greetings,
    Atanas Valchev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • Thanks! That fixed the issue!

    O.
  • Yep! Fixed here too.
    Deleting the two .config files was the key.

    Cheers,
    Geoff